Network Management

Reply

LDAP authentication in Airwave 8.2

Hi.

 

I have been trying to setup LDAP integrated authentication for a couple of days now, and I'm getting nowhere. I have enabled LDAP authentication, tryed using both FQDN and IP-addresses for DC's, tryed all combinations of ports and connection type I can think of. Tryed with different accounts, but still the result is "Wrong username or password".

 

If i look at the security log in the DC's I can see that the BIND account gets authenticated, so that seems correct. I have tryed looking through the messages log on the server (under /var/logs) but I can't find anything there.

 

The DC's are two Windows Sevrer 2008R2 and one Windows Server 2012R2.

 

How do one go about troubleshooting this? We have a RADIUS server that also chould be used but it seems a bit odd to have to use a extra service for this functionality when it should support LDAP directly.

 

Best regards,

Johan Christensson

Re: LDAP authentication in Airwave 8.2

Hi,

 

Just got this working in my lab.

 

ldap.jpg

 

Bind DN : CN=ldap,OU=Service Accounts,DC=lab,DC=lan

 

Cheers

James

Cheers
James

-------------------------------------------------------
-------------------@whereisjrw-------------------
------------------------blog-------------------------
ACCX #540 | ACMX #353 | ACDX #216
-----------Mobility First Expert #11----------
-------------------------------------------------------

If a reply adequately addresses your issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.

Re: LDAP authentication in Airwave 8.2

Thanks jrwhitehead

 

I was wondering if the fact that I have spaces in the OU names could have anything to do with the problem, but that works for you so... I also wounded if the group specified in the LDAP Rule have to be in the same OU as the user accounts, but again, I pretty sure that the group "Domain Admins" is not in the path of you Base DN.

 

And I have also tried with different user accounts, and I have no strange characters in the password for the either the Bind account or the user account I'm testing with.

 

This is strange and a bit frustrating..... There must be some log in the Airwave system that shows something....

 

Best regards,

Johan Christensson

Re: LDAP authentication in Airwave 8.2

I've been working on this today. I've have success to a certain degree. The LDAP authentication is working but the LDAP rule to map to a role is not what I expect. If I try to use the "memberof" and "equals" I cannot get a role to work. If I use "memberof" and "contains" with the group name I have success. I've tried using the CN, full distinguished name, name with quotes but nothing seems to work with "equals". Any ideas?

 

Thanks,

Ricki

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: