Network Management

Reply
Occasional Contributor II

Upgrading AMP to version 8.2.5.1 from version 8.0.9.2.

Hi,

 

Trying to update an AMP instance from 8.0.9.2, but I get an error message and the installer terminates, as it misses a rabbitmq service.

Is there a version that I need to upgrade to first, before going to 8.2.5.1?

 

Here's the output of the installation:

 

Validating the upgrade package...

Verifying authenticity of the upgrade package....

Verifying signature....

Good Signature....

Verifying checksum....

Upgrade package verified....

Upgrading AMP to version 8.2.5.1 from version 8.0.9.2...

Detailed log will be written to /var/log/upgrade/AMP-8.2.5.1-upgrade.log

 

STEP 1: Moving old version aside.

 

STEP 2: Unpacking upgrade package.

 

STEP 3: Checking for compatibility.

 

STEP 4: Stopping AMP services.

 

STEP 5: Installing upgrade.

rabbitmq-server: unrecognized service

        Parallel::Forker::poll('Mercury::Parallel::Forker=HASH(0xfcaa518)') called at /opt/airwave/local/lib/perl5/site_perl/5.10.1/Parallel/Forker.pm line 94

        Parallel::Forker::wait_all('Mercury::Parallel::Forker=HASH(0xfcaa518)') called at /root/git/mercury/bin/update_db.pl line 211

        update_db::go('update_db') called at /root/git/mercury/bin/update_db.pl line 228

do_update_db failed with 65280

make[1]: *** [updatedb] Error 1

make[1]: Leaving directory `/root/git/mercury'

make: *** [upgrade] Error 2

make: Leaving directory `/root/git/mercury'

goldy: unrecognized service

rabbitmq-server: unrecognized service

 

 

Upgrade aborted.

Please contact Aruba Networks Support at

1-800-WiFi-LAN (US & Canada) or 1-408-754-1200 (International Toll) or http://www.hpe.com/networking/mynetworking

DISABLED - 2!!

svn: E155007: '/root/svn/mercury' is not a working copy

 

Let me know please if I am missing something.

 

BR,

Levente

Moderator

Re: Upgrading AMP to version 8.2.5.1 from version 8.0.9.2.

What's the upgrade history on your server?  (cat /var/log/upgrade/*history*)

 

The upgrade unit tests passed for a direct upgrade from 8.0.9.2, so it should have worked unless there's an issue that came from a prior upgrade.  You might try to upgrade to one of the release end points: 8.0.11.2 / 8.2.3.1 / 8.2.4.1.  And then upgrade to 8.2.5.1 from there.

 

Beyond that, you might need to open a case so that TAC can see what's blocking the upgrade.

 

From the release notes, these were the tested upgrade paths:

Supported Upgrade Paths
You can upgrade directly to AirWave 8.2.5.1 from the following software versions:
 8.0.8 through 8.0.11.2
 8.2.0 through 8.2.3.1
 8.2.4 through 8.2.4.1
 8.2.5


Rob Gin
Senior QA Engineer - Network Services
Aruba Networks, a Hewlett Packard Enterprise Company
Occasional Contributor II

Re: Upgrading AMP to version 8.2.5.1 from version 8.0.9.2.

Hi Rob,

Thanks for the follow-up. This one has gone through a couple of upgrades, according to the upgrade log:

Mon May 21 13:13:51 CEST 2012 From: 7.3.4 To: 7.4.8 - Starting upgrade.

Mon May 21 13:20:19 CEST 2012 From: 7.3.4 To: 7.4.8 - Upgrade successful.

Tue Feb 26 11:14:34 CET 2013 From: 7.4.8 To: 7.6.2 - Starting upgrade.

Tue Feb 26 11:22:15 CET 2013 From: 7.4.8 To: 7.6.2 - Upgrade successful.

Wed Apr 30 15:21:33 CEST 2014 From: 7.6.2 To: 7.6.6 - Starting upgrade.

Wed Apr 30 15:33:16 CEST 2014 From: 7.6.2 To: 7.6.6 - Upgrade successful.

Tue May 13 12:54:08 GMT+1 2014 From: 7.6.6 To: 7.7.11 - Starting upgrade.

Tue May 13 13:03:56 GMT+1 2014 From: 7.6.6 To: 7.7.11 - Upgrade successful.

Wed Dec 16 07:11:00 GMT+1 2015 From: 7.7.11 To: 8.0.9.2 - Starting upgrade.

Wed Dec 16 07:18:18 GMT+1 2015 From: 7.7.11 To: 8.0.9.2 - Upgrade successful.

 

I will try now - based on your suggestion - to update it to 8.0.11.2 first, and then moving to 8.2.5.1.

 

Thanks,

Levente

New Contributor

Re: Upgrading AMP to version 8.2.5.1 from version 8.0.9.2.

Hi,

I have similar error log during upgrade from 8.0.11.2.

 

Validating the upgrade package...

Verifying authenticity of the upgrade package....

Verifying signature....

Good Signature....

Verifying checksum....

Upgrade package verified....

Upgrading AMP to version 8.2.5.1 from version 8.0.11.2...

Detailed log will be written to /var/log/upgrade/AMP-8.2.5.1-upgrade.log

 

STEP 1: Moving old version aside.

 

STEP 2: Unpacking upgrade package.

 

STEP 3: Checking for compatibility.

 

STEP 4: Stopping AMP services.

 

STEP 5: Installing upgrade.

rabbitmq-server: unrecognized service

        Parallel::Forker::poll('Mercury::Parallel::Forker=HASH(0xf929c38)') called at /opt/airwave/local/lib/perl5/site_perl/5.10.1/Parallel/Forker.pm line 94

        Parallel::Forker::wait_all('Mercury::Parallel::Forker=HASH(0xf929c38)') called at /root/git/mercury/bin/update_db.pl line 211

        update_db::go('update_db') called at /root/git/mercury/bin/update_db.pl line 228

do_update_db failed with 65280

 

 

Anyone know what it could be ?

 

Regards,

Robert

 

 

 

 

Moderator

Re: Upgrading AMP to version 8.2.5.1 from version 8.0.9.2.

Need more of the upgrade log to determine the issue.  It might also be more beneficial to upgrade from 8.0.9.2 -> 8.2.3 -> 8.2.5.1

 

note that 8.2.6 will be posted this week or next week (I'm trying to post it today actually).


Rob Gin
Senior QA Engineer - Network Services
Aruba Networks, a Hewlett Packard Enterprise Company
Occasional Contributor II

Re: Upgrading AMP to version 8.2.5.1 from version 8.0.9.2.

I opened a case and an engineer helped me sorting it out. The solution was to apply those steps he highlighted in his email:

"

  • Take a snapshot in VM.
  • From CLI, please execute the below commands to fix the missing indices.

# root
# fix_missing_indices

  • Once is executed, now upgrade the server to 8.2.5.1. From AMP 8.2.4, Engineering restricted the root access to the CLI and we need to set the password for 'ampadmin' user which will populate at the end of 8.2.5.1 upgrade. Please make sure we set the password for 'ampadmin' user.

"

 

Anyway, try to go through these, and hopefully you will have an updated, working system again.


Cheers,

Levente

New Contributor

Re: Upgrading AMP to version 8.2.5.1 from version 8.0.9.2.

We are working on it using small steps.

So, after upgrade from 8.0.11.2 to 8.2.3.1 we have working AMP.

But:

After STEP6, APM is asking to 

STEP 6: Restarting AMP services.

*********************************************************

Run fix_missing_indices to fix the missing indices.

*********************************************************

And we have similar errors regarding PATHs.

Can't locate Mercury/Scripts/CompareSchemaWithExpected.pm in @INC  ...

...

But after reload we run that command again and everything is ok. Command was finished successfully. 

Probably in next step we will try to upgrade AMP from 8.2.3.1 to 8.2.5.1

 

I will let you know.

New Contributor

Re: Upgrading AMP to version 8.2.5.1 from version 8.0.9.2.

Success, upgrade to 8.2.5.1 is finished. 

 

 

Occasional Contributor I

Re: Upgrading AMP to version 8.2.5.1 from version 8.0.9.2.

Great, good job!
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: