Network Management

Reply
Occasional Contributor II
Posts: 19
Registered: ‎05-14-2015

trying to upgrade from 8.2.2 to 8.2.3.1

having issues going from 8.2.2 to 8.2.3.1.  

 

error: open of ../node_js/npm/openssl-devel-aruba-1.0.2h-1.el6.x86_64.rpm failed: No such file or directory
make[3]: *** [security_patches] Error 1
make[3]: Leaving directory `/root/git/mercury/src/x86_64/rpms/CentOS-6'
make[2]: *** [perllib] Error 2
make[2]: Leaving directory `/root/git/mercury/src'
make[1]: *** [src_install] Error 2
make[1]: Leaving directory `/root/git/mercury'
make: *** [upgrade] Error 2
make: Leaving directory `/root/git/mercury

 

Really starting to get bugged with this update issues.  CentOS is current final version 6.8. there are no OpenSSL updates.  I am not sure if the problem is with perllib or not.  I am downloading 8.2.2.1 and 8.2.3 now to try stepping up to each version in between. Currently running 8.2.2.  

 

Yum reports there is no perllib package to install. 

 

Aruba Employee
Posts: 440
Registered: ‎02-19-2015

Re: trying to upgrade from 8.2.2 to 8.2.3.1

Share complet upgrade log from /var/log/upgrade directory and below outputs

 

#root;amp_version

#root;git show

 

Regards,

Pavan

Occasional Contributor II
Posts: 19
Registered: ‎05-14-2015

Re: trying to upgrade from 8.2.2 to 8.2.3.1

amp_version = 8.2.2

git show: command not found. 

 

See the attached log. 

 

 

Aruba Employee
Posts: 440
Registered: ‎02-19-2015

Re: trying to upgrade from 8.2.2 to 8.2.3.1

make[3]: Entering directory `/root/git/mercury/src'
error: Failed dependencies:
    fontconfig-devel is needed by (installed) gd-devel-2.0.35-11.el6.x86_64
    freetype-devel is needed by (installed) gd-devel-2.0.35-11.el6.x86_64
error: Failed dependencies:
    libpng-devel is needed by (installed) gd-devel-2.0.35-11.el6.x86_64
make[3]: Leaving directory `/root/git/mercury/src'
/usr/bin/make -C /root/git/mercury/src/x86_64/rpms/CentOS-6 install_for_perllib
make[3]: Entering directory `/root/git/mercury/src/x86_64/rpms/CentOS-6'
CentOS release 6.8 (Final)
error: open of ../node_js/npm/openssl-devel-aruba-1.0.2h-1.el6.x86_64.rpm failed: No such file or directory
make[3]: *** [security_patches] Error 1

 

 

could you install below packages and recompile the code

# yum install fontconfig-devel-*

# yum install libpng-devel*

#root;make




Contributor II
Posts: 36
Registered: ‎01-14-2014

Re: trying to upgrade from 8.2.2 to 8.2.3.1

We have the same issue upgrading our Airwave. 

 

  • Checked the /root directory and found that we have both SVN and GIT folder present and Airwave was trying to use SVN folder instead of GIT
  • Moved the SVN folder to /tmp directory
  • Went to the path /root/git/mercury and ran make to recompile the script

Hope this help, but please get an aruba Tac assist while doing this.

Aruba Employee
Posts: 440
Registered: ‎02-19-2015

Re: trying to upgrade from 8.2.2 to 8.2.3.1

Edgar,

 

Solution you have provided is for when make fail to run from root prompt. If we have old svn and new svn file in same /root directory, make is failing. Moving old svn file to tmp directory and initiating make command works.

 

Issue here is not of make, it is caused due to dependecies, installing those dependencires will fix the issue.

 

Regards,

Pavan

Occasional Contributor II
Posts: 19
Registered: ‎05-14-2015

Re: trying to upgrade from 8.2.2 to 8.2.3.1

I thought that originally but they appeared to be installed, Yum reports they are already installed and there is nothing to do.

 

Package fontconfig-devel-2.8.0-5.el6.x86_64 already installed and latest version
Nothing to do

 

Package 2:libpng-devel-1.2.49-2.el6_7.x86_64 already installed and latest version
Nothing to do

 

Aruba Employee
Posts: 440
Registered: ‎02-19-2015

Re: trying to upgrade from 8.2.2 to 8.2.3.1

Have you tried recompile the code again? If yes and still throwing same dependencies error message then I beileve you are doing something wrong.

 

I would recommand to open TAC case to troubleshoot the issue further.

 

Regards

Pavan

Occasional Contributor II
Posts: 19
Registered: ‎05-14-2015

Re: trying to upgrade from 8.2.2 to 8.2.3.1

Well, I tried to go from 8.2.2 to 8.2.2.1 and got issues again.  So I opened a TAC ticket. thanks

Search Airheads
Showing results for 
Search instead for 
Did you mean: