Security

Reply
SJS
New Contributor
Posts: 3
Registered: ‎04-27-2015

API-205 and PacketFence

[ Edited ]

hey all,

 

I am using a API-205 and PacketFence ZEN version as external Captive Portal.

 

Now I want to connect them with Inline Enforcement and over the Virtual Controller of the Access Point.

 

If I try to connect to the WLAN on my phone I get redirected to the portal and I'm also able to login, but after the login I still got no connection to the internet.

 

Does anyone have a clue how I need to configure the AP or is the problem maybe on the PacketFence configuration?

 

Regards,

 

SJS

MVP
Posts: 740
Registered: ‎04-13-2009

Re: API-205 and PacketFence

Hi,

 

After login is the user in a role on the Instant web interface that should allow internet access?

 

Might well be a packetfence issue....

 

Cheers

James

Cheers
James

-------------------------------------------------------
-------------------@whereisjrw-------------------
------------------------blog-------------------------
ACCX #540 | ACMX #353 | ACDX #216
-----------Mobility First Expert #11----------
-------------------------------------------------------

If a reply adequately addresses your issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.
SJS
New Contributor
Posts: 3
Registered: ‎04-27-2015

Re: API-205 and PacketFence

No the user is still in the wrong Role.

I made 2 Roles one for preAuth and one after which is the standard Role, but the user is still in the preAuth Role.

 

The standard role is the one with internet access.

 

Regards,

 

SJS

 

SJS
New Contributor
Posts: 3
Registered: ‎04-27-2015

Re: API-205 and PacketFence

hi,

 

I found the configuration file from my API-205, it's in the attachment.

 

And on the PacketFence I made under Configuration -> Switches a switch:
IP: 192.168.12.3 (from the virtual controller)
Type: Aruba 200 Controller
Mode Production
Deauthentucation Method: RADIUS
Dynamic Uplinks: active
Inline mode if any of the following conditions are met: always
Radius Passphrase: Same as on the Access Point

 

And the rest is on default.

 

maybe this will help :)

 

Cheers,
SJS

MVP
Posts: 740
Registered: ‎04-13-2009

Re: API-205 and PacketFence

Hi,

 

Have you configured role mapping on switch configuration on the PacketFence? I don't know much about PacketFence but I'm assuing you'll need to configure the "Role by Switch Role" section in your switch config.

 

To me it soundsmore like a PacketFence config issuerather than something on your Instant config.

 

Cheers

James

Cheers
James

-------------------------------------------------------
-------------------@whereisjrw-------------------
------------------------blog-------------------------
ACCX #540 | ACMX #353 | ACDX #216
-----------Mobility First Expert #11----------
-------------------------------------------------------

If a reply adequately addresses your issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.
Search Airheads
Showing results for 
Search instead for 
Did you mean: