Security

Reply
Frequent Contributor II
Posts: 149
Registered: ‎04-20-2009

Android 6.0 connection problems. TLS1.2 ???

I am having an issue with Android tablets running Android ver 6.0 where the
tablet connects to my 802.1x authenticated SSID, successfully authenticates
according to the auth logs on Clearpass but will not connect to the SSID.
The Tablet says there is an authentication problem. CPPM shows the tablet
as having successfully authenticated and sends the accept message along
with user-role attributes back to the controller as it should. The client
is not in the controller's user table.

I understand this may have something to do with the processing of EAP/TLS
but The SSID in question is using PEAP/MsCHAPv2

 

Controller OS version 6.4.2.4
CPPM Version 6.5.1.72346

 

Guru Elite
Posts: 8,456
Registered: ‎09-08-2010

Re: Android 6.0 connection problems. TLS1.2 ???

Upgrade to the latest ClearPass release. It was patched in 6.5.2. 


Thanks, 
Tim

Tim Cappalli | Aruba Security TME
@timcappalli | timcappalli.me | ACMX #367 / ACCX #480
Frequent Contributor II
Posts: 149
Registered: ‎04-20-2009

Re: Android 6.0 connection problems. TLS1.2 ???

Thanks Tim.

I am assuming that because I am not terminating on my controllers that I will not need to update their code. I am currently running version 6.4.2.4. Am I correct in this thinking or should I be looking at a controller update as well?

 

Cheers.

Guru Elite
Posts: 8,456
Registered: ‎09-08-2010

Re: Android 6.0 connection problems. TLS1.2 ???

Correct. You do not need to upgrade the controllers. 


Thanks, 
Tim

Tim Cappalli | Aruba Security TME
@timcappalli | timcappalli.me | ACMX #367 / ACCX #480
Occasional Contributor I
Posts: 7
Registered: ‎02-16-2014

Re: Android 6.0 connection problems. TLS1.2 ???

[ Edited ]

ad patching ClearPass to version 6.5.2 solved your issue?

Frequent Contributor II
Posts: 149
Registered: ‎04-20-2009

Re: Android 6.0 connection problems. TLS1.2 ???

Spoiler
vasya.
Yes the upgrade to ver6.2 solved the issue. Everything has been working perfectly since the upgrade.
New Contributor
Posts: 1
Registered: ‎06-04-2015

Re: Android 6.0 connection problems. TLS1.2 ???

Awesome,  We have the same problem,  so I will give this a go.  Thanks very much

Search Airheads
Showing results for 
Search instead for 
Did you mean: