Security

Reply
New Contributor

External Captive Portal

Hello,

Ok so I had a test IAP 215 from Aruba for testing before purchase. I setup Radius and my own captive portal for guest access. Everything was working great so before giving back the demo I backed up the config. 

Purchased new IAP 315 restored the config from the test device and that loaded the config great. But now I cannot login through the captive portal and it seems to have to do with this line in the index file  <form method=POST action="http://securelogin.arubanetworks.com/cgi-bin/login"> with this it will just spin and spin till i get a webpage not available. FYI once someone logs in it takes them to my companies .edu page. If I change it to this  <form method=POST action="https://securelogin.arubanetworks.com/cgi-bin/login"> it will ask to add the certificate and I can login fine. But I didn't need that https in the previous config. 
Any help with this would be great thanks

Alex

Guru Elite

Re: External Captive Portal

Did you upload your captive portal certificate?

Tim Cappalli | Aruba Security TME
@timcappalli | timcappalli.me | ACMX #367 / ACCX #480
New Contributor

Re: External Captive Portal

I did not upload a captive portal cert. I did not know I had to as it worked fine previously with the test device.

thanks

New Contributor

Re: External Captive Portal

How do I upload this cert? Is this becase when restoring from the previous device it is using that Cert?

thanks

Guru Elite

Re: External Captive Portal

The cert previously included was not designed to be used in production environments. Please take a look here:

https://community.arubanetworks.com/t5/Controller-less-WLANs/ArubaOS-Default-Certificate-Revocation-FAQ-Instant/ta-p/275814

Tim Cappalli | Aruba Security TME
@timcappalli | timcappalli.me | ACMX #367 / ACCX #480
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: