Security

Reply
Frequent Contributor I
Posts: 60
Registered: ‎09-16-2014

Internal Aruba Captive Portal Page Not Auto PromptAruba Captive Portal Page Not Auto Prompt

Hi,

I've setup captive portal authentication for my site. My setup is using Aruba internal captive portal.My problem is after connected to ssid and  launch browser, the page will not automatically launch. I need to type 1.1.1.1 then the page will come out. i've checked on the rules and all is fine. When I type the IP address instead of securelogin.arubanetworks.com i will go to controller login page. I nslookup securelogin.arubanetworks.com it can resolve controller's ip address.

Guru Elite
Posts: 19,974
Registered: ‎03-29-2007

Re: Internal Aruba Captive Portal Page Not Auto PromptAruba Captive Portal Page Not Auto Prompt

The controller always hijacks dns requests for securelogin whether DNS works or not.  Try to resolve other names to make sure DNS is working correctly.

Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Validated Reference Design Guides : http://community.arubanetworks.com/t5/Validated-Reference-Design/tkb-p/Aruba-VRDs
Frequent Contributor I
Posts: 60
Registered: ‎09-16-2014

Re: Internal Aruba Captive Portal Page Not Auto PromptAruba Captive Portal Page Not Auto Prompt

Hi Colin,

 

You mean from controller itself resolve the dns?

Guru Elite
Posts: 19,974
Registered: ‎03-29-2007

Re: Internal Aruba Captive Portal Page Not Auto PromptAruba Captive Portal Page Not Auto Prompt

No.  Make sure the client can resolve hostnames.  Use nslookup.  

Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Validated Reference Design Guides : http://community.arubanetworks.com/t5/Validated-Reference-Design/tkb-p/Aruba-VRDs
Frequent Contributor I
Posts: 60
Registered: ‎09-16-2014

Re: Internal Aruba Captive Portal Page Not Auto PromptAruba Captive Portal Page Not Auto Prompt

Hi,

 

Found out this was due to dns issue. They block internet access for that vlan. I put google dns as dns ip at dhcp setting. Thanks for your assistance.

Search Airheads
Showing results for 
Search instead for 
Did you mean: