Security

Reply
Contributor I
Posts: 21
Registered: ‎05-31-2011

Issues with IPhones connecting to open Wireless network

So whenever we get in a new iphone and try and connect it to our open public wireless it will sometimes take hours to connect. Once it has connected we can reconnect it without any issues. It just seems to be the first time when we try connecting a new phone it will take a very long time to connect.

 

I have tried reseting my windows phone to factory defaults and reconnecting to the same public wireless network and it connects right away.

 

Has anyone else had issues like this?

MVP
Posts: 561
Registered: ‎11-28-2011

Re: Issues with IPhones connecting to open Wireless network

What version of code is your controller (or instant APs) running? Also, have you changed any of the ARM, radio or SSID settings from the defaults?

Kudos appreciated, but I'm not hunting! (ACMX 104)
Contributor I
Posts: 21
Registered: ‎05-31-2011

Re: Issues with IPhones connecting to open Wireless network

I am running ArubaOS 6.1.3.1 on the controller and this open public network has been running for a little over two years and it is just in the last 60 days we have noticed this issue.

MVP
Posts: 4,012
Registered: ‎07-20-2011

Re: Issues with IPhones connecting to open Wireless network

 

 

Make sure your DHCP server is not running out of IP address .

 

Can you please share the config on your Virtual AP Profile and SSID Profile ?

show wlan virtual-ap <virtual ap name>

 

show wlan ssid-profile <ssid profile>

 

Also share the initial role config 

 

show rights <role name>

 

Is the device able to associate : show ap association client-mac 

 

Does this happens at certain times of the day ? or it is a very consistent issue ?

Thank you

Victor Fabian
Lead Mobility Engineer @ Integration Partners
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
Contributor I
Posts: 21
Registered: ‎05-31-2011

Re: Issues with IPhones connecting to open Wireless network

It might just be my DHCP server running out of addresses. I didn't even think about that. Let me check this out over the next couple of days and I will get back to you!

MVP
Posts: 1,110
Registered: ‎10-11-2011

Re: Issues with IPhones connecting to open Wireless network

Also, it may be helpful to run a user debug:

 

1) Get the MAC of the device having issues

2) Issue the following command in global configuration mode: logging level debugging user-debug mac-address-of-device

3) Connect the device to your network to recreate the issue

4) Search the user-debug log for potential issues: show log user-debug all | inc mac-address-of-device

5) Search all logs for other issues: show log all | inc mac-address-of-device

6) Provide any of the above information that you're comfortable sharing in this thread.

=======================================
If a reply adequately addresses your issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users.
Contributor I
Posts: 21
Registered: ‎05-31-2011

Re: Issues with IPhones connecting to open Wireless network

It looks like victorfabian was right with the DHCP server running out of addresses. I added more IP addresses to be available and all devices are working fine now. Today I have 558 active leases out of 1021. Before i increased the number of addresses being leased out I was only offering 510 leases which obviously wouldn't accomidate 558 machines.

 

Thanks for the help!

Search Airheads
Showing results for 
Search instead for 
Did you mean: