Security

Reply
New Contributor
Posts: 2
Registered: ‎08-26-2013

LDAP Auth => Aruba650 w/6.1.3.8 to MS 2008R2

Greetings, I realize that there have probably been a thousand threads on this. Having problems getting Aruba 650 controller to do LDAP auth against a Microsoft 2008R2 AD environment. Keep getting error as follows:

 

" authmgr[1580]: <199802> |authmgr| ldapclient.c, ldap_auth_api:124: Invalid authentication protocol 4 for LDAP"

 

Any help would be greatly appreciated.

Guru Elite
Posts: 8,649
Registered: ‎09-08-2010

Re: LDAP Auth => Aruba650 w/6.1.3.8 to MS 2008R2

[ Edited ]

Is this for captive portal authentication?

 

Change your authentication type to PAP under the Captive Portal Authentication Profile.

 

captive-portal-pap.png


Tim Cappalli | Aruba Security TME
@timcappalli | timcappalli.me | ACMX #367 / ACCX #480
Guru Elite
Posts: 21,291
Registered: ‎03-29-2007

Re: LDAP Auth => Aruba650 w/6.1.3.8 to MS 2008R2


mjt-texas wrote:

Greetings, I realize that there have probably been a thousand threads on this. Having problems getting Aruba 650 controller to do LDAP auth against a Microsoft 2008R2 AD environment. Keep getting error as follows:

 

" authmgr[1580]: <199802> |authmgr| ldapclient.c, ldap_auth_api:124: Invalid authentication protocol 4 for LDAP"

 

Any help would be greatly appreciated.


Please see the article here:  https://arubanetworkskb.secure.force.com/pkb/articles/Troubleshooting/R-41 for an LDAP configuration and troubleshooting example.



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

New Contributor
Posts: 2
Registered: ‎08-26-2013

Re: LDAP Auth => Aruba650 w/6.1.3.8 to MS 2008R2

[ Edited ]

At this point, just trying to get the server provision under Authentication / Servers / LDAP and then tested under Diagnostics.

 

UPDATE!!!! -- Got it!  -- I had the base DN incorrect.  When I brought it up a level and issued the query user command as referenced in the article you posted, it worked.  Validated I was using the wrong OU for the test user.  Once fixed, works like a champ!

 

THANKS!

 

--MJT

Search Airheads
Showing results for 
Search instead for 
Did you mean: