Security

Reply
Regular Contributor I
Posts: 279
Registered: ‎02-11-2013

Self Service Area not enabled

[ Edited ]

Hi,

 

I have a strange problem with CP Guest. I use the Guest self-registration, it works fine, guests can log in and go to the Internet.

 

But if I would like to access the Self Service Area with my username and password, I got this message : Guest registration is not currently enabled and in the url I can read .../guest/guest_register_portal.php?result=offline.

 

SelfServicePortal_5.JPG

 

SelfServicePortal_2.JPG

 

In CP Guest, self-service portal is enabled.

 

SelfServicePortal_1.JPG

 

So I don't understand what I am doing wrong. It only happends thru the IAP because if I try it in CP Guest by the link "Go to Portal", I can log in and access the portal and see all the info.

 

Any idea ?

 

Regards,

 

Dimitri

Aruba
Posts: 1,540
Registered: ‎06-12-2012

Re: Self Service Area not enabled

If you unchecked the UI override do you get the same error?

 

I sent your request off to engineering and will let you know when I hear back.

Thank You,
Troy

--Give Kudos: found something helpful, important, or cool? Click Kudos Star in a post.

--Problem Solved? Click "Accepted Solution" in a post.
Regular Contributor I
Posts: 279
Registered: ‎02-11-2013

Re: Self Service Area not enabled

Hi,

 

Yes, I get the same error.

 

I don't know if it's the correct behavior because after being logged, if I come back to the guest portal, I can access the Self Service Area with no difficulties.

 

Thanks for your help.

 

Dimitri

MVP
Posts: 4,226
Registered: ‎07-20-2011

Re: Self Service Area not enabled

[ Edited ]

 

Make sure you are not missing any updates / plugins .

 

 

Thank you

Victor Fabian
Lead Mobility Engineer @ Integration Partners
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
Regular Contributor I
Posts: 279
Registered: ‎02-11-2013

Re: Self Service Area not enabled

ClearPass is up to date and all plugins are enabled.

Aruba
Posts: 1,540
Registered: ‎06-12-2012

Re: Self Service Area not enabled

Here is a quick note from engineering. I will keep looking into it. I did some testing in my lab and Im running the latest 6.1.1 and I had no issues.

 

"Are you sure you are on the latest released patch?  There was an issue where the portal settings of a custom self-registration were being ignored and it was always using the settings from guest_register.  Workaround is to enable the setting under guest_register.  Best solution is 6.1.1."

Thank You,
Troy

--Give Kudos: found something helpful, important, or cool? Click Kudos Star in a post.

--Problem Solved? Click "Accepted Solution" in a post.
Regular Contributor I
Posts: 279
Registered: ‎02-11-2013

Re: Self Service Area not enabled

CP Guest version is 6.1.1.24938.

 

So if I enable the portal under guest_register and then try to access my custom portal, I am redirected to the guest_register one. So there is something here that is not working properly.

 

Thanks

 

Dimitri

Aruba
Posts: 1,540
Registered: ‎06-12-2012

Re: Self Service Area not enabled

Sounds like it.

Was this a

fresh install?
backup and restore?

I would recommend opening a TAC case. If you want to upload a back up and email the address I can take a look if I get some free time.

Troy Arnold
Systems Engineer - ClearPass Specialist
US Central
tarnold@arubanetworks.com
Thank You,
Troy

--Give Kudos: found something helpful, important, or cool? Click Kudos Star in a post.

--Problem Solved? Click "Accepted Solution" in a post.
Regular Contributor I
Posts: 279
Registered: ‎02-11-2013

Re: Self Service Area not enabled

[ Edited ]

It was a fresh install then update to 6.1.1.

 

Yes, I can send you a backup. But stupid question, where can I backup CP Guest ? I know for CPPM but for CP Guest ?

 

Thanks

 

Regards,

Regular Contributor I
Posts: 279
Registered: ‎02-11-2013

Re: Self Service Area not enabled

More information to try to solve this problem. There is something strange.

 

This is my Self Service Login page

 

Portal_1.JPG

 

When I log in, I am redirected to this page :

 

Portal_2.JPG

 

I can log in and see my portal

 

Portal_3.JPG

Search Airheads
Showing results for 
Search instead for 
Did you mean: