Security

Reply
Occasional Contributor II
Posts: 16
Registered: ‎01-10-2014

Stuck at Captive Portal Login

Hi Guys,

 

I'm hoping someone can help me out here.

 

I'm setting up a basic guest captive portal with internal DB auth. Here are some details...

 

Roles:

winterfell-guest-logon (logon-control + captiveportal)(captive portal profile = winterfell-guest-cp-auth-prof)

winterfell-guest-authenticated (deny-internal-networks + allow all)

 

Captive Portal Auth Profile

winterfell-guest-cp-auth-prof (default role = winterfell-guest-authenticated)

login page (see more below) - /upload/custom/winterfell-guest-cp-auth-prof/winterfell-cp-page.html

welcome page disabled

redirect url - http://www.google.com

 

AAA profile

winterfell-guest-aaa-prof ( initial role - winterfell-guest-logon)

 

The "winterfell-cp-page.html" is a carbon copy of the HTML from the default captive portal page. I have not changed anything in the code. I plan to change the CSS file it will use once I can get the auth to work but that's a seperate thing for now.

 

So here is what the problem is...

 

I connect to the winterfell-guest ssid

Check user table and see I am in winterfell-guest-logon role. Great!

I open a web browser and navigate to anywebsitehere.com.

I get redirected to the captive portal. Great!

I enter in the credentials of the single user in the internal database and click Log In.

The web browser processes that for a second or two and I am presented with the captive portal login page, again.

I check the user table and I am still in the winterfell-guest-logon role.

 

If go in and change the captive portal profile used by "winterfell-guest-logon" back to "default" everything works. My role is chaged to "winterfell-guest-authenticated" and I am redirected to google.com (I changed that in the default CP prof).

 

I'm really hoping someone can provide some insight here. I'm lost.

 

Thanks in advance!

 

 

 

 

Occasional Contributor II
Posts: 16
Registered: ‎01-10-2014

Re: Stuck at Captive Portal Login

Current OS is 6.4.2.12. Upgrading to 6.4.3.4 currently to see if that helps.

 

 

Occasional Contributor II
Posts: 16
Registered: ‎01-10-2014

Re: Stuck at Captive Portal Login

The upgrade made no impact.

Aruba
Posts: 1,635
Registered: ‎04-13-2009

Re: Stuck at Captive Portal Login

[ Edited ]

Doublecheck the "default role" that is listed in your Captive Portal profile?  This is the role that will be assigned to the user after they sucessfully login.    Also, check to see if you if your server group you are using (internal/default/etc.) has a server rule applied that is assigning the role assigned to the user in the internal DB.

 

Lastly, run the following after you attempt your login and view the Role Derivation; it will tell you how the role was assigned.

 

 

------------------------------------------------
Systems Engineer, Northeast USA
ACCX | ACDX | ACMX

Occasional Contributor II
Posts: 16
Registered: ‎01-10-2014

Re: Stuck at Captive Portal Login

Hi clembo, thanks for your input.

 

I have triple checked the default role under the "winterfell-guest-cp-auth-prof" profile and it is correctly configured for "winterfell-guest-authenticated"

 

I wouldn't have thought to check your second suggestion. No luck though, no rule in place there.

 

I'm not sure what you are saying for the last part. The role isnt changing from "winterfell-guest-logon" after the credentials are supplied. If I run the command to show how it was derived would it not be from the AAA profile "winterfell-guest-aaa-prof"? Also, what is the command so I can give it a shot anyway?

 

Thanks.

Guru Elite
Posts: 20,017
Registered: ‎03-29-2007

Re: Stuck at Captive Portal Login

If you are authenticating a user with username and password, the default role it what that user should get.  The default guest role only applies if you have guest login checked and the user is only putting in his/her email address for authentication.

 

Maybe you should run your HTML by TAC so that you can have it checked...

 

Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Validated Reference Design Guides : http://community.arubanetworks.com/t5/Validated-Reference-Design/tkb-p/Aruba-VRDs
MVP
Posts: 470
Registered: ‎05-11-2011

Re: Stuck at Captive Portal Login

Try to re-create the html, but not by copy/past the default. Check out page 338-> in the 6.4 UserGuide and start with the pure basics to verify that it works before applying more html to the portal. Might be just some tiny error caused by the copy/paste.

This is the minimum you need:

<HTML>
<HEAD>
</HEAD>
<BODY>
<FORM method="post" autocomplete="off" ACTION="/auth/index.html/u">
Username:<BR>
<INPUT type="text" name="user" accesskey="u" SIZE="25" VALUE="">
<BR>
Password:<BR>
<INPUT type="password" name="password" accesskey="p" SIZE="25"
VALUE="">
<BR>
<INPUT type="submit">
</FORM>
</BODY>
</HTML>

 

And/or just add the file here and we can take a look at it :)

 

Regards
John Solberg

-ACMX #316 :: ACCP-
Intelecom - Norway
----------------------------
Remember to Kudo if a post helped you! || Problem Solved? Click "Accept as Solution" in a post!
Occasional Contributor II
Posts: 16
Registered: ‎01-10-2014

Re: Stuck at Captive Portal Login

Thanks jsolb! I ended up using the basic HTML you posted and it works so I will start with that and build off it to customize.

MVP
Posts: 470
Registered: ‎05-11-2011

Re: Stuck at Captive Portal Login

Glad to have helped. Good luck with the project!
Regards
John Solberg

-ACMX #316 :: ACCP-
Intelecom - Norway
----------------------------
Remember to Kudo if a post helped you! || Problem Solved? Click "Accept as Solution" in a post!
Search Airheads
Showing results for 
Search instead for 
Did you mean: