Security

Reply
Occasional Contributor II
Posts: 10
Registered: ‎02-08-2012

Welcome page not showing on iPad; No ability to log off guest network.

Hi everyone,

 

I can't be the only person experiencing this issue.  I'll describe the behavior step by step.

 

  1. User selects the ClearPass SSID from the list of available wireless networks.
  2. Connection is made, ClearPass login window is automatically brought up by the iPad.
  3. User logs on to the ClearPass guest network, but the screen is automaticaly minimized before the Welcome page is loaded.
  4. User then has no ability to get back to the welcome page! Now, the user cannot log out from their iPad to free up a device for their ClearPass account.

Is there any kind of fix for this? Obviously it has to be serverside, I cant depend on everyone with an iPad to change their settings.

Open to any ideas, thanks guys

Moderator
Posts: 150
Registered: ‎11-14-2011

Re: Welcome page not showing on iPad; No ability to log off guest network.

What you are seeing is what Apple calls the Captive Network Assistant and it is not a full version of the Safari browser. ClearPass Guest has an option to bypass this usability feature in iOS to allow you to display post login welcome pages as you describe. Details on the bypass capabilities are discussed on the following post:

 

http://community.arubanetworks.com/t5/Community-Knowledge-Base/Bypass-the-Apple-Captive-Network-Assistant-with-Amigopod/ta-p/16659

Occasional Contributor II
Posts: 10
Registered: ‎02-08-2012

Re: Welcome page not showing on iPad; No ability to log off guest network.

Wow what an easy fix. Thank you so much.

For anyone else interested, just change your loginpage from amigopod/aruba_login.php to amigopod/landing.php/aruba_login.php

Occasional Contributor II
Posts: 27
Registered: ‎01-29-2009

Re: Welcome page not showing on iPad; No ability to log off guest network.

We are experiencing the same issue with Welcome Page for iOS devices.


We are not using Amigopod or clearpass, just Standard Aruba controller Captive Portal with Welcome page.

 

Do you know of any work-around solution for this setup?  I don't believe there is on.

 

Actually, it is a little comforting to see a verified cause to this issue.  I had a Aruba TAC ticket open for over a week and after explaining issue time and time again, I don't believe the engineer ever truly believed me.

 

 

Aruba Employee
Posts: 37
Registered: ‎11-04-2011

Re: Welcome page not showing on iPad; No ability to log off guest network.

[ Edited ]

You should be able to whitelist www.apple.com in your preauth role to prevent the CNA from firing.

Occasional Contributor II
Posts: 10
Registered: ‎02-08-2012

Re: Welcome page not showing on iPad; No ability to log off guest network.

This fix has actually stopped working for us

landing.php worked when first implemented, then we switched the HTTPS and removed the landing.php.

 

We didn't notice again till today, but the CNA is back.  Https authentication is suppose to prevent it, however this doesn't appear to be the case.  Also  enabling HTTPS and landing.php at the same time doesn't have any effect.  The only thing we haven't tried is going back to http and landing.php.  Does the landing.php page only work with http, not HTTPS?  We're live right now so Im hesitant to go back to http

 

Can anyone else confirm they're using HTTPS for their captive portal and the Apple CNA is still working?

 

Thank you

Search Airheads
Showing results for 
Search instead for 
Did you mean: