Security

Reply
Occasional Contributor I

When setting up a Google admin context server We get a non-public domain error back from Google.

When setting up a Google admin context server We get a non-public domain error back from Google. The error is:

 

Error: invalid_request

Invalid parameter value for redirect_uri: Non-public domains not allowed: https://OPCS-ClearPass/async_netd/mdm/oauth/google

 

When we setup Google it had we had the correct public domain information: https://OPCS-ClearPass.opschools.org/async_netd/mdm/oauth/google

Re: When setting up a Google admin context server We get a non-public domain error back from Google.

Did you defined FQDN for ClearPass under Administration > Server Configuration > System Tab
Thank you

Victor Fabian
Lead Mobility Engineer @ Integration Partners
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
Occasional Contributor I

Re: When setting up a Google admin context server We get a non-public domain error back from Google.

Yes I did..

 

 OP-FQDN.JPG

Re: When setting up a Google admin context server We get a non-public domain error back from Google.

Hello,

Is this problem solved. I am running in exactly the same problem

clearpsss 6.6.8. and configured clearpass with a FQDN. So same problem as above,  It seems that Clearpsss goes out without the FQDN.

In the URL that pops up with the error, there is no FQDN  but just de clearpass hostname. Manual  adding/modifying this URL with the FQDN name gives a correct  responce from google. So how can we solve this!

 

Gerrit

Guru Elite

Re: When setting up a Google admin context server We get a non-public domain error back from Google.

Enter the ClearPass FQDN in the FQDN field in the server configuration.

Tim Cappalli | Aruba Security TME
@timcappalli | timcappalli.me | ACMX #367 / ACCX #480

Re: When setting up a Google admin context server We get a non-public domain error back from Google.

That's is  what I configured,( before posting) but didn't help

I configured the FQDN name in Server configuration field.  

Clearpass still ony uses the Hostname!

 

Gerrit

 

Guru Elite

Re: When setting up a Google admin context server We get a non-public domain error back from Google.

Screenshot of your server config screen please.

Tim Cappalli | Aruba Security TME
@timcappalli | timcappalli.me | ACMX #367 / ACCX #480

Re: When setting up a Google admin context server We get a non-public domain error back from Google.

Hi,
Here is the screenshot of my server config, as you can see the FQDN is configured
FQDN.jpg
When I Authorize Clearpass in the context server
Clearpass-auth.png
I receive the message:
Invalid parameter value for redirect_uri: Non-public domains not allowed: https://cp-hak3/async_netd/mdm/oauth/google
When I manually modify the URL in the popup screen of the error to https://cp-hak3.hak3.nl/async_netd/mdm/oauth/google
Google seems te accept this.

Gerrit




Guru Elite

Re: When setting up a Google admin context server We get a non-public domain error back from Google.

Please open a TAC case.

Tim Cappalli | Aruba Security TME
@timcappalli | timcappalli.me | ACMX #367 / ACCX #480
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: