Security

Reply
MVP
Posts: 765
Registered: ‎03-25-2009

custom boolean

So I'm trying to configure a session limit that is 4 per default but has one exception.

Some users need to be able to create a users that either have the default 4 session limit or have unlimited sessions.

 

This exception I've got working with a dropdown list that selects either 4 or 0. However I'm stuck trying to create a boolean version of the "simultaneous_use" form field. Ideally the user could tick a checkbox to activate unlimited sessions for this user.

 

So, how do I edit the boolean settings so that

when the box is unchecked it actualy saves a 4 instead of a 1?

when the box is unchecked it actualy saves a 4 instead of a 1?

 

 

Koen (ACMX #351 | ACDX #547 | ACCP)

-- Found something helpful, important, or cool? Click the Kudos Star in a post.
-- Problem Solved? Click "Accept as Solution" in a post.
Aruba
Posts: 1,644
Registered: ‎04-13-2009

Re: custom boolean

[ Edited ]

If I understand correctly, you want to display a checkbox on the create guest page.  If checked, unlimited sessions are allowed; if not, the default is used (4 in your case)?

 

If so, try this:

- Set 4 as the session default (Configuration --> Guest Manager)

- Add simultaneous_use to the Create User form you are using

- Edit the field (not base)

- Change User Interface to Checkbox

- Change Label (maybe something like "Unlimited Sessions?")

- Change Description (maybe something like "Enable for unlimited sessions")

- Change checkbox value to 0 (for unlmited)

 

cppm-simul-check.png

 

This will show the following on the form.  If you check it, unlimited simultaneous sessions is set.  If you leave it unchecked, the default of 4 is kept.

 

cppm-simul-check1.png

 

 

The result is the following (for checked and unchecked)

 

cppm-simul-check2.png

------------------------------------------------
Systems Engineer, Northeast USA
ACCX | ACDX | ACMX

MVP
Posts: 765
Registered: ‎03-25-2009

Re: custom boolean

[ Edited ]

Thanks, we missed the default setting in guest manager and changed all our fields to include the simultaneous_use field with a default value of 4.

With a default of 4 in the checkbox config you can't get it working.

 

Anyway, problem solved.. much appreciated!

Koen (ACMX #351 | ACDX #547 | ACCP)

-- Found something helpful, important, or cool? Click the Kudos Star in a post.
-- Problem Solved? Click "Accept as Solution" in a post.
Search Airheads
Showing results for 
Search instead for 
Did you mean: