Security

Reply
Contributor II
Posts: 49
Registered: ‎01-16-2013

enforce-dhcp not working - 6.4.3.7

I've recently started setting up a small WLAN for fixed-ip (static) devices.  I've duplicated my AAA profile and added the "enforce-dhcp" option to it and use it only for my static WLAN.

 

So using a fixed-ip that comes from the DHCP server works ok:

 

# show user-table  ip 1.1.1.2 detail | include DHCP
Address is from DHCP: yes
  DHCP role: n/a, Default role: cp-logon, Cached role: n/a

 

But when I set the same system (MBair) with a static IP address, it still continues to work, incorrectly stating that the Address is from DHCP.  I've verified that the DHCP server did not hand out this address.

 

# show user-table  ip 1.1.1.3 detail | include DHCP
Address is from DHCP: yes
  DHCP role: n/a, Default role: cp-logon, Cached role: n/a

 

The DHCP address shows up in the route-cache, but the static IP does not.  Interestingly though, even after setting the static and clearing the route-cache, it still remains.

 

# show datapath route-cache table | include f4:f8:f5:fE:fF:fC
1.1.1.2      f4:f8:f5:fE:fF:fC         2016  H

#clear datapath route-cache 1.1.1.2                                    
#clear datapath route-cache 1.1.1.2
# show datapath route-cache table | include f4:f8:f5:fE:fF:fC
1.1.1.2      f4:f8:f5:fE:fF:fC         2016  H

 

 

I've never used enforce-dhcp in the past to be able to say if the new ArubaOS version isn't working or my concept isn't working.

 

thanks

mike

 

Mike Davis
Network Engineer
University of Delaware
Guru Elite
Posts: 20,820
Registered: ‎03-29-2007

Re: enforce-dhcp not working - 6.4.3.7

Please open a TAC case, so that they can investigate whether this is a bug or not.



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Search Airheads
Showing results for 
Search instead for 
Did you mean: