Security

Reply
Contributor II
Posts: 90
Registered: ‎12-06-2014

guest cert issues

I just deployed Clearpass guest with PSK. windows users who were previously connected to Guest and now getting certifiacte warning and want to import a new certificate. How can I resolve this so users are not getting the popup warning? 

Guru Elite
Posts: 7,842
Registered: ‎09-08-2010

Re: guest cert issues

Do you have a captive portal configured?


Thanks,
Tim

Tim Cappalli | Aruba ClearPass TME
@timcappalli | ACMX #367 / ACCX #480 / ACEAP / CWSP
Contributor II
Posts: 90
Registered: ‎12-06-2014

Re: guest cert issues

yes - sorry left that out 

Guru Elite
Posts: 7,842
Registered: ‎09-08-2010

Re: guest cert issues

Do you have a public certificate installed?

If clients are attempting to access a secure site, they will likely get the certificate error. Unfortunately there's no way around this.


Thanks,
Tim

Tim Cappalli | Aruba ClearPass TME
@timcappalli | ACMX #367 / ACCX #480 / ACEAP / CWSP
Contributor II
Posts: 90
Registered: ‎12-06-2014

Re: guest cert issues

The cert its using would be the one under CPPM/administration/certificates/server certs ? 

 

Its a public signed Geotrust cert 

Guru Elite
Posts: 7,842
Registered: ‎09-08-2010

Re: guest cert issues

Yes. Unfortunately this will happen if users are trying to access a secure website.


Thanks,
Tim

Tim Cappalli | Aruba ClearPass TME
@timcappalli | ACMX #367 / ACCX #480 / ACEAP / CWSP
Contributor II
Posts: 90
Registered: ‎12-06-2014

Re: guest cert issues

Curious, how is it considered secure?  How do I make this unsecure ;-) 

 

yes I understand the risks

Guru Elite
Posts: 7,842
Registered: ‎09-08-2010

Re: guest cert issues

You would have to disable SSL for your captive portal. But you will still get the occasional redirect cert mismatch.


Thanks,
Tim

Tim Cappalli | Aruba ClearPass TME
@timcappalli | ACMX #367 / ACCX #480 / ACEAP / CWSP
Contributor II
Posts: 90
Registered: ‎12-06-2014

Re: guest cert issues

I have the captive portal on the instant controller to use port 80 and disable https. Is there another location? 

Aruba Employee
Posts: 571
Registered: ‎04-17-2009

Re: guest cert issues

In CPG->Configuration->Authentication uncheck "Require HTTPS for guest access"

 

Screen Shot 2015-08-19 at 1.10.52 PM.png

 

This will prevent the client from being redirected from port 80 to HTTPS on the ClearPass side.

Thanks,

Zach Jennings
Search Airheads
Showing results for 
Search instead for 
Did you mean: