Reply
New Contributor
ramaramon
Posts: 1
Registered: ‎08-30-2013

External Captive Portal Redirect IP Problem

Hi All,

 

We are configuring external captive portal integration on Aruba Controller OAW-4604, SW release  6.2.1.3.

We are having problem on redirection to captive portal. When Aruba controller redirects user traffic to external captive portal, the source IP from user traffic is being changed to Aruba controller's loopback IP address, instead of user's correct source IP address. As a result, when our captive portal calls Aruba XML API to initiate authentication process, the API call is using wrong IP (loopback IP) and we get following error:

 

<aruba>
<status>Error</status>
<code>3</code>
<reason>unknown external agent</reason>
</aruba>

 

We were previously using SW release 3.4.2 on Aruba Controller and we had no issues, external captive portal was working correctly with same network setup. This problem appeared only after we upgraded to AOS 6.2.1.3. Have been browsing Aruba documentation but found not issues on our configuration, any clues why this might be happening?

 

Please let me know.


Thanks & Regards

Aruba
clembo
Posts: 1,178
Registered: ‎04-13-2009

Re: External Captive Portal Redirect IP Problem

The source IP will change to the controller's IP (in this case the loopback) if you have src-nat set in the firewall policy or for the VLAN.  Can you check the following.

 

show rights <name-of-logon-role>

show vlan status (check the Nat Inside column for that VLAN)

 

------------------------------------------------
Systems Engineer, Northeast USA
Email: clembo@arubanetworks.com

New Contributor
PTURNER-PCC
Posts: 1
Registered: ‎12-06-2011

Re: External Captive Portal Redirect IP Problem

Should the NAT inside be enabled or disabled?