Wireless Access

Reply
Occasional Contributor I
Posts: 8
Registered: ‎12-03-2012

AP-105 not connecting back to controller after IP address change.

I recently changed the IP address on the controller to better match my network topology and while the majority of the APs (120+) have come up, I have have 5 that are being a pain.  I have consoled into one of them to determine that it is receiving the new Master IP address, but it will not connect.  I also performed a 'purgeenv' and a 'factory_reset' on the AP before power cycling it just to see if that would help.

 

 

Any assistance would be greatly appreciated.

 

 

APBoot 1.2.4.4 (build 26618)
Built: 2011-01-07 at 13:42:04

Model: AP-10x
CPU: AR7161 revision: A2
Clock: 680 MHz, DDR clock: 340 MHz, Bus clock: 170 MHz
DRAM: 128 MB
POST1: passed
Copy: done
Flash: 16 MB
PCI: scanning bus 0 ...
dev fn venID devID class rev MBAR0 MBAR1 MBAR2 MBAR3
00 00 168c 0029 00002 01 10000000 00000000 00000000 00000000
01 00 168c 0029 00002 01 10010000 00000000 00000000 00000000
Net: eth0
Radio: ar922x#0, ar922x#1

Hit <Enter> to stop autoboot: 0
Checking image @ 0xbf100000
Invalid image format version: 0xffffffff
Checking image @ 0xbf800000
Invalid image format version: 0xffffffff
eth0 up: 100 Mb/s full duplex
DHCP broadcast 1
DHCP IP address: 10.33.61.5
DHCP subnet mask: 255.255.255.0
DHCP def gateway: 10.33.61.254
DHCP DNS server: 0.0.0.0
DHCP DNS domain: goddardusd.com
Controller address: 10.10.61.62
Using eth0 device
TFTP from server 10.10.61.62; our IP address is 10.33.61.5; sending through gateway 10.33.61.254
Filename 'mips32.ari'.
Load address: 0x2000000
Loading: T T T T T T T T T T
Retry count exceeded; starting again
eth0 up: 100 Mb/s full duplex
DHCP broadcast 1
DHCP IP address: 10.33.61.5
DHCP subnet mask: 255.255.255.0
DHCP def gateway: 10.33.61.254
DHCP DNS server: 0.0.0.0
DHCP DNS domain: goddardusd.com
Controller address: 10.10.61.62
Using eth0 device
TFTP from server 10.10.61.62; our IP address is 10.33.61.5; sending through gateway 10.33.61.254
Filename 'mips32.ari'.
Load address: 0x2000000
Loading: T T T T T T T T T T
Retry count exceeded; starting again

MVP
Posts: 1,409
Registered: ‎05-28-2008

Re: AP-105 not connecting back to controller after IP address change.

Hi,

1.What ArubaOS version are u using?

2.Are u sure that the AP cant use TFTP (in order to get the AOS version from the controller) ? from 10.33.XX to 10.10.. check icmp and 3.check that u arent blocking TFTP (UDP 69)

4.Also check that the GW of that vlan allowing all the need traffic to pass from the AP to the controller.

 

TFTP from server 10.10.61.62; our IP address is 10.33.61.5; sending through gateway 10.33.61.254

it's seems that something is blocking the connectivity via TFTP port from the AP to the controller new ip

Retry count exceeded; starting again

 

 

*****************2Plus Wireless Solutions****************************
Aruba Airheads - Powered By community for empower the community
************ Don't Forget to Kudos + me,If i helped you******************
Aruba
Posts: 233
Registered: ‎11-19-2009

Re: AP-105 not connecting back to controller after IP address change.

From below output, I could "invalid image format" Can you please check if we are able to ping gateway and controller ip address from apboot mode and try to swap with any of the working AP port connected to the swich to see if that makes any difference.

 

apboot> clear os

apboot> save

apboot>reset

 

Please try clearing the os on the ap just to see if in case ap flash got corrupted.

 

Thank you.

 

MVP
Posts: 1,409
Registered: ‎05-28-2008

Re: AP-105 not connecting back to controller after IP address change.

Did u remmberd to reboot your controller after the ip change? ( dont forget to save config)

*****************2Plus Wireless Solutions****************************
Aruba Airheads - Powered By community for empower the community
************ Don't Forget to Kudos + me,If i helped you******************
Occasional Contributor I
Posts: 8
Registered: ‎12-03-2012

Re: AP-105 not connecting back to controller after IP address change.

Controller Version is 6.1.3.3

 

Controller was rebooted after the IP address change. Will try 'clear os' to see if that provides communication back and report my findings.

 

Thanks for the quick responses.

Occasional Contributor I
Posts: 8
Registered: ‎12-03-2012

Re: AP-105 not connecting back to controller after IP address change.

AP can ping both the gateway and the controller from the '~ # ' prompt.    I can ping the AP from the controller, but am still not getting the radios to come on.

 

Please assist.

Occasional Contributor I
Posts: 8
Registered: ‎12-03-2012

Re: AP-105 not connecting back to controller after IP address change.

I have posted the latest information from the AP as an attachment.

Aruba
Posts: 233
Registered: ‎11-19-2009

Re: AP-105 not connecting back to controller after IP address change.

Thanks and can you run the show log system all and show datapath sessin table | include <ap ip address> to see if what traffic we could see on the controller from the AP. Please attach those outputs to review.

Occasional Contributor I
Posts: 8
Registered: ‎12-03-2012

Re: AP-105 not connecting back to controller after IP address change.

After adding a second set of eyes to the configuration, it was pointed out that I had the wrong "help address" in the configuration.  Instead of pointing the APs to 10.10.61.62, I should have been pointing them to 10.0.61.62.  Once this change was made and the APs rebooted, all came up as expected.  Thank you all for your assistance in this matter.

 


 

Aruba
Posts: 233
Registered: ‎11-19-2009

Re: AP-105 not connecting back to controller after IP address change.

Great to hear that AP`s came up fine now. Thank you.

Search Airheads
Showing results for 
Search instead for 
Did you mean: