Wireless Access

Reply
Contributor II

AP binds to channels not part of regulatory domain profile

I am using the "default" regulatory domain profile for USA, which has 1, 6 and 11 as available 802.11g channels.  However, when I do show ap active, I see APs bound to channels 5 and 7, as well.  Does anybody have any idea why this is happening?

 

# show ap act

Active AP Table
---------------
Name Group IP Address 11g Clients 11g Ch/EIRP/MaxEIRP 11a Clients 11a Ch/EIRP/MaxEIRP AP Type Flags Uptime Outer IP
---- ----- ---------- ----------- ------------------- ----------- ------------------- ------- ----- ------ --------
aruba-hsq-16-e1 ggg 192.168.82.234 7 AP:HT:11/22.5/22.5 1 AP:HT:44+/23/23 105 BdaK 9d:4h:56m:42s N/A
aruba-wbw-3-w1 ggg 192.168.109.61 5 AP:HT:11-/22.5/22.5 3 AP:HT:161-/24/24 105 BdaK 9d:5h:0m:21s N/A
aruba-nyc-4-w1 ggg 192.168.107.69 5 AP:HT:11-/22.5/22.5 1 AP:HT:40-/23/23 105 BdaK 9d:5h:0m:50s N/A
aruba-wbw-3-e1 ggg 192.168.109.64 2 AP:HT:5-/22.5/22.5 6 AP:HT:44+/23/23 105 BdaK 9d:4h:58m:48s N/A
aruba-nss-8-1 ggg 192.168.96.83 4 AP:HT:1+/22.5/22.5 1 AP:HT:48-/23/23 105 BdaK 9d:4h:59m:57s N/A
aruba-nyc-5-w1 ggg 192.168.109.90 1 AP:HT:5-/12/22.5 0 AP:HT:153-/24/24 105 BdaK 9d:4h:56m:31s N/A
aruba-aoa-27-e1 ggg 192.168.195.18 0 AP:HT:5-/22.5/22.5 0 AP:HT:153-/24/24 105 BdaK 51d:21h:14m:12s N/A
aruba-nyc-2-w1 ggg 192.168.109.96 9 AP:HT:11/22.5/22.5 1 AP:HT:40-/23/23 105 BdaK 6d:20h:11m:57s N/A
aruba-nyc-5-w2 ggg 192.168.109.74 9 AP:HT:1/22.5/22.5 0 AP:HT:44+/23/23 105 BdaK 9d:5h:1m:41s N/A
aruba-nyc-4-e1 ggg 192.168.107.58 10 AP:HT:11/22.5/22.5 4 AP:HT:153-/24/24 105 BdaK 9d:5h:0m:38s N/A
aruba-nss-7-1 ggg 192.168.96.68 5 AP:HT:5-/22.5/22.5 2 AP:HT:161-/24/24 105 BdaK 9d:5h:0m:12s N/A
aruba-wbw-4-w1 ggg 192.168.109.99 2 AP:HT:7+/21/22.5 2 AP:HT:36+/23/23 105 BdaK 9d:5h:0m:33s N/A
aruba-wbw-4-e1 ggg 192.168.82.134 3 AP:HT:7+/18/22.5 1 AP:HT:157+/24/24 105 BdaK 9d:4h:57m:6s N/A
aruba-nyc-3-e1 ggg 192.168.107.61 2 AP:HT:5-/22.5/22.5 2 AP:HT:36+/23/23 105 BdaK 9d:5h:0m:52s N/A
aruba-hou-10-n1 ggg 192.168.67.1 0 AP:HT:11/22.5/22.5 2 AP:HT:48-/23/23 105 BdaK 3d:11h:40m:57s N/A
aruba-hou-10-s1 ggg 192.168.67.2 3 AP:HT:1/22.5/22.5 0 AP:HT:157+/24/24 105 BdaK 3d:11h:40m:56s N/A
aruba-nyc-5-e1 ggg 192.168.109.60 2 AP:HT:5-/18/22.5 0 AP:HT:48-/23/23 105 BdaK 9d:5h:0m:33s N/A
aruba-hsq-16-w1 ggg 192.168.82.233 4 AP:HT:7+/22.5/22.5 5 AP:HT:48-/23/23 105 BdaK 9d:4h:56m:39s N/A
aruba-nyc-5-e2 ggg 192.168.109.83 4 AP:HT:11/22.5/22.5 0 AP:HT:36+/23/23 105 BdaK 9d:5h:1m:33s N/A

Flags: a = Reduce ARP packets in the air; A = Enet1 in active/standby mode;
B = Battery Boost On; C = Cellular; D = Disconn. Extra Calls On;
d = Drop Mcast/Bcast On; E = Wired AP enabled; K = 802.11K Enabled; n = Don't convert IPv6 Mcast RA to Ucast
L = Client Balancing Enabled; M = Mesh; N = 802.11b protection disabled;
P = PPPOE; R = Remote AP; X = Maintenance Mode;
2 = Using IKE version 2;

Retired Employee

Re: AP binds to channels not part of regulatory domain profile

Please check the corresponding ARM profile for the APs. And paste the output. Check the field for "allowed bands for 40MHz."

 

(master) #show rf arm-profile default

Adaptive Radio Management (ARM) profile "default"
-------------------------------------------------
Parameter Value
--------- -----
Assignment single-band
Allowed bands for 40MHz channels a-only


--
HT
Contributor II

Re: AP binds to channels not part of regulatory domain profile

Confirmed:

#show rf arm-profile ts-arm

Adaptive Radio Management (ARM) profile "ts-arm"
------------------------------------------------
Parameter Value
--------- -----
Assignment single-band
Allowed bands for 40MHz channels a-only

 

Retired Employee

Re: AP binds to channels not part of regulatory domain profile


garryshtern wrote:

Confirmed:

#show rf arm-profile ts-arm

Adaptive Radio Management (ARM) profile "ts-arm"
------------------------------------------------
Parameter Value
--------- -----
Assignment single-band
Allowed bands for 40MHz channels a-only

 


garryshtern, 

 

I did a quick test on my setup and here is what I observer 

 

(master) (config) #show rf arm-profile default

Adaptive Radio Management (ARM) profile "default"
-------------------------------------------------
Parameter Value
--------- -----
Assignment single-band
Allowed bands for 40MHz channels a-only

 

 

AP on channel 6 


Active AP Table
---------------
Name Group IP Address 11g Clients 11g Ch/EIRP/MaxEIRP 
---- ----- ---------- ----------- ------------------- 

RAP105 rap 2.2.2.1 0 AP:HT:6/9/22.5 0

 

 

 I changed the 40-MHz allowed bands to "All" 

(master) (Adaptive Radio Management (ARM) profile "default") #40MHz-allowed-bands All
(master) (Adaptive Radio Management (ARM) profile "default") #exit

 

(acmx-master) (config) #show rf arm-profile default

Adaptive Radio Management (ARM) profile "default"
-------------------------------------------------
Parameter Value
--------- -----
Assignment single-band
Allowed bands for 40MHz channels All

 

And as soon as I changed this, the AP got the following channel (7+)

Active AP Table
---------------
Name Group IP Address 11g Clients 11g Ch/EIRP/MaxEIRPOuter IP
---- ----- ---------- ----------- ------------------- -----------
RAP105 rap 2.2.2.1 0 AP:HT:7+/9/22.5 

 

 

Can you please confirm that none of the ARM profiles have this setting as "All / g-only" 

 

Quick way to do this would be 

(acmx-master) (config) #show rf arm-profile default

Adaptive Radio Management (ARM) profile "default"
-------------------------------------------------
Parameter Value
--------- -----
Assignment single-band
Allowed bands for 40MHz channels All

 

Thanks, 

--
HT
Contributor II

Re: AP binds to channels not part of regulatory domain profile

All of them are good:

# show rf arm-profile

Adaptive Radio Management (ARM) profile List
--------------------------------------------
Name References Profile Status
---- ---------- --------------
arm-maintain 2
arm-scan 2
default 4
ts-arm 2

Total:4

#show rf arm-profile arm-maintain | include "Allowed bands"
Allowed bands for 40MHz channels a-only

#show rf arm-profile arm-scan | include "Allowed bands"
Allowed bands for 40MHz channels a-only

#show rf arm-profile default | include "Allowed bands"
Allowed bands for 40MHz channels a-only

#show rf arm-profile ts-arm | include "Allowed bands"
Allowed bands for 40MHz channels a-only

 

Retired Employee

Re: AP binds to channels not part of regulatory domain profile

garryshtern

 

We will need more information to figure out why are the APs selecting 40MHz channels. Please open up a TAC case so that they can look into the information and provide an answer. 

 

If you want to prevent APs from taking up those channels then you could remove them from the 

ap regulatory-domain-profile 

 

(master) (config) #ap regulatory-domain-profile default     

(master) (Regulatory Domain profile "default") #no valid-11g-40mhz-channel-pair 1-5   

(master) (Regulatory Domain profile "default") #no valid-11g-40mhz-channel-pair 7-10 

(master) # write memory 



--
HT
Contributor I

Re: AP binds to channels not part of regulatory domain profile

Just one thought.... in the AP group, are the AP's assigned the US regulatory domain or perhaps a different?

Guru Elite

Re: AP binds to channels not part of regulatory domain profile


garryshtern wrote:

All of them are good:

# show rf arm-profile

Adaptive Radio Management (ARM) profile List
--------------------------------------------
Name References Profile Status
---- ---------- --------------
arm-maintain 2
arm-scan 2
default 4
ts-arm 2

Total:4

#show rf arm-profile arm-maintain | include "Allowed bands"
Allowed bands for 40MHz channels a-only

#show rf arm-profile arm-scan | include "Allowed bands"
Allowed bands for 40MHz channels a-only

#show rf arm-profile default | include "Allowed bands"
Allowed bands for 40MHz channels a-only

#show rf arm-profile ts-arm | include "Allowed bands"
Allowed bands for 40MHz channels a-only

 


To see what profiles are responsible for your AP settings, type:

 

show ap config ap-name <name of ap> | include Channel

 It will tell you what profile is responsible for setting the channel on that AP.



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Contributor II

Re: AP binds to channels not part of regulatory domain profile

It is set to "default" which is used by my AP group, and the default doesn't have any 40Mhz bonding:

 

#show ap regulatory-domain-profile default

Regulatory Domain profile "default"
-----------------------------------
Parameter Value
--------- -----
Country Code US
Valid 802.11g channel 1
Valid 802.11g channel 6
Valid 802.11g channel 11
Valid 802.11a channel 36
Valid 802.11a channel 40
Valid 802.11a channel 44
Valid 802.11a channel 48
Valid 802.11a channel 149
Valid 802.11a channel 153
Valid 802.11a channel 157
Valid 802.11a channel 161
Valid 802.11a channel 165
Valid 802.11g 40MHz channel pair N/A
Valid 802.11a 40MHz channel pair 36-40
Valid 802.11a 40MHz channel pair 44-48
Valid 802.11a 40MHz channel pair 149-153
Valid 802.11a 40MHz channel pair 157-161

 

Also, the channel for the AP that is currently on 5 is set to "N/A":

#show ap active

Active AP Table
---------------

...snip....

aruba-wbw-3-e1   ***  ***  0            AP:HT:5-/22.5/22.5   1            AP:HT:44+/23/23      105      BdaK   9d:9h:4m:42s    N/A

 

#show ap config ap-name aruba-wbw-3-e1 | include Channel
Channel N/A N/A rf dot11g-radio-profile "AP" / rf dot11a-radio-profile "AP"
RX Sensitivity Tuning Based Channel Reuse disable disable rf dot11g-radio-profile "AP" / rf dot11a-radio-profile "AP"
Free Channel Index 25 25 rf arm-profile "ts-arm"

 

Retired Employee

Re: AP binds to channels not part of regulatory domain profile

Do you have ARM assignment set to "maintain" ? 

If the APs selected those channels earlier and then the configuration was set to maintain then the APs would stay on that channel.

 

show rf arm-profile <profile> | include Assignment 

 

--
HT
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: