Wireless Access

Reply
Occasional Contributor II
Posts: 10
Registered: ‎02-22-2011

AP not upgrading after Controller upgrade

We just ran into an issue where a large number of APs would not come back online after we upgraded our controllers to 6.1.3.8.  The controllers saw the AP and indicated that they were upgrading, but the APs continued to reboot.  TAC looked into it and said that there is a network connectivity problem because "Show AP database" showed the APs with the ID flags set.  TAC had me move an AP to a different vlan and it magically upgraded and came back online.  My confusion with the issue is that I have other APs on the same original vlan that worked just fine.   I continued to have issues with APs upgrading for about a day. Some did not upgrade even with changing vlans. 

I dug a little deeper in the "Show AP Database long" command and see that the "Slot/Port" column to be random.  Sometimes pc-0 or pc-1 which I would assume to be the port channels leading to our two core Cisco 6509 switch.  (Controllers are layer 3 connected to core switches, Core switches have a layer 3 10 gig between them) I also see APs with a slot/port of "?/?" and 1/9.   Slot 1/9 is the VRRP layer 2 interconnect between the two controllers.  Currently all of our APs are on the second controller. Not sure why the APs would show up on the 1/9 interface?   Is this correct functionality? Are these APs really passing traffic? 

 

Eric Kurtz

Susquehanna University

MVP
Posts: 1,408
Registered: ‎05-28-2008

Re: AP not upgrading after Controller upgrade

  • From Which OS you upgraded to 6.1.3.8?
  • Your AP'S are from what model?
  • if u are using VRRP - i will assume you are working in MASTER  MASTER STANDBY mode. if so only one controller control your AP. (until a fail-over) Please print out your VRRP config cli output from both controllers
  • Also -> Printout the printenv (or install / provision  AP screen from gui) - u might have misconfigured your unit..

 

ME.

 

*****************2Plus Wireless Solutions****************************
Aruba Airheads - Powered By community for empower the community
************ Don't Forget to Kudos + me,If i helped you******************
Occasional Contributor II
Posts: 10
Registered: ‎02-22-2011

Re: AP not upgrading after Controller upgrade

We upgraded from 6.1.3.6 to 6.1.3.8.

We are currently running all AP-105

We are using a master local setup with 2 instances of VRRP.  One from Controller 0 --> Contoller 1 and one from Controller 1 --> Controller 0 .  We had APs on both  controllers to spread out the load, but had an unrelated issue so we moved all the APs for controller 1 till we finished the semester. 

 

We have a number of VRRP instances running due to vlan pooling.

Controller 0

Virtual Router 1:     Description

    Admin State UP, VR State MASTER

    IP Address 10.200.1.1, MAC Address 00:00:5e:00:01:01, vlan 2001

    Priority 100, Advertisement 1 sec, Preemption Enable Delay 0

    Auth type NONE ********

    tracking is not enabled

Virtual Router 101:

    Description

    Admin State UP, VR State BACKUP

    IP Address 10.200.1.2, MAC Address 00:00:5e:00:01:65, vlan 2001

    Priority 99, Advertisement 1 sec, Preemption Enable Delay 0

    Auth type NONE ********

    tracking is not enabled

Virtual Router 111:

    Description

    Admin State UP, VR State MASTER

    IP Address 10.199.0.1, MAC Address 00:00:5e:00:01:6f, vlan 1901

    Priority 100, Advertisement 1 sec, Preemption Enable Delay 0

    Auth type NONE ********

    tracking is not enabled

Virtual Router 112:

    Description

    Admin State UP, VR State MASTER

    IP Address 10.199.4.1, MAC Address 00:00:5e:00:01:70, vlan 1902

    Priority 100, Advertisement 1 sec, Preemption Enable Delay 0

    Auth type NONE ********

    tracking is not enabled

 

Controller 1

 

(ArubaSEI1) #show Vrrp

Virtual Router 1:    

  Description    

  Admin State UP, VR State BACKUP    

  IP Address 10.200.1.1, MAC Address 00:00:5e:00:01:01, vlan 2001    

  Priority 99, Advertisement 1 sec, Preemption Enable Delay 0    

  Auth type NONE ********    

  tracking is not enabled

Virtual Router 101:    

Description    

Admin State UP, VR State MASTER    

IP Address 10.200.1.2, MAC Address 00:00:5e:00:01:65, vlan 2001    

Priority 100, Advertisement 1 sec, Preemption Enable Delay 0    

Auth type NONE ********   

 tracking is not enabled

Virtual Router 111:   

 Description    

Admin State UP, VR State BACKUP   

 IP Address 10.199.0.1, MAC Address 00:00:5e:00:01:6f, vlan 1901  

  Priority 99, Advertisement 1 sec, Preemption Enable Delay 0    

Auth type NONE ********   

 tracking is not enabled

Virtual Router 112:    

Description    

Admin State UP, VR State BACKUP   

 IP Address 10.199.4.1, MAC Address 00:00:5e:00:01:70, vlan 1902    

Priority 99, Advertisement 1 sec, Preemption Enable Delay 0   

 Auth type NONE ********   

 tracking is not enabled

 

Occasional Contributor II
Posts: 10
Registered: ‎02-22-2011

Re: AP not upgrading after Controller upgrade

So for example, here are some of our APs.  They are connected to the same switch in the same vlan but have different slot/ports.

 

(ArubaSEI1) #show ap database long | include WSTE

WSTE-0CLounge-AP105  SusqCtrl1VRRP  105      172.26.23.58  Up 7d:11h:19m:9s          6c:f3:7f:cb:a2:8f  BT0347105  pc-1

WSTE-0SW012-AP105    SusqCtrl1VRRP  105      172.26.23.59  Up 7d:11h:19m:6s          6c:f3:7f:cb:a2:84  BT0347094  pc-1

WSTE-1NW101-AP105    SusqCtrl1VRRP  105      172.26.23.55  Up 7d:11h:19m:7s          6c:f3:7f:cb:a2:7e  BT0347088  pc-0

WSTE-1SE107-AP105    SusqCtrl1VRRP  105      172.26.23.52  Up 7d:11h:19m:37s         6c:f3:7f:cb:a2:7f  BT0347089  1/9

WSTE-2NE210-AP105    SusqCtrl1VRRP  105      172.26.23.57  Up 7d:11h:19m:8s          6c:f3:7f:cb:a2:83  BT0347093  pc-1

WSTE-2SW204-AP105    SusqCtrl1VRRP  105      172.26.23.51  Up 7d:11h:19m:46s         6c:f3:7f:cb:a2:8d  BT0347103  1/9

WSTE-3NW301-AP105    SusqCtrl1VRRP  105      172.26.23.56  Up 7d:11h:19m:10s         6c:f3:7f:cb:a2:8b  BT0347101  pc-0

WSTE-3SE307-AP105    SusqCtrl1VRRP  105      172.26.23.54  Up 7d:11h:19m:4s          6c:f3:7f:cb:a2:78  BT0347082  pc-0

 

(ArubaSEI1) #show ap database long | include NO18

NO18-2N103-AP105    SusqCtrl1VRRP  105      10.131.36.24  Up 4d:23h:29m:45s         6c:f3:7f:cb:a2:77  BT0347081  pc-1

NO18-2N302-AP105    SusqCtrl1VRRP  105      10.131.36.22  Up 5d:23h:20m:53s         6c:f3:7f:cb:a2:6f  BT0347073  pc-1

NO18-2N502-AP105    SusqCtrl1VRRP  105      10.131.36.23  Up 5d:23h:20m:53s         6c:f3:7f:cb:a2:8c  BT0347102  pc-1

NO18-2N701-AP105    SusqCtrl1VRRP  105      10.131.36.21  Up 5d:23h:20m:54s         6c:f3:7f:cb:94:6e  BT0343488  ?/?

 

(ArubaSEI1) #show ap database long | include BR18

BR18-2B102-AP105      SusqCtrl1VRRP  105      10.131.25.25  Up 6d:5h:53m:1s           6c:f3:7f:cb:96:a1  BT0344051  pc-0

BR18-2B201-AP105      SusqCtrl1VRRP  105      10.131.25.24  Up 6d:5h:53m:1s           6c:f3:7f:cb:96:a9  BT0344059  ?/?

BR18-2B401-AP105      SusqCtrl1VRRP  105      10.131.25.23  Up 6d:5h:53m:0s           6c:f3:7f:cb:96:a4  BT0344054  pc-0

BR18-2B502-AP105      SusqCtrl1VRRP  105      10.131.25.22  Up 6d:5h:52m:59s          6c:f3:7f:cb:96:95  BT0344039  pc-0

BR18-2B601-AP105      SusqCtrl1VRRP  105      10.131.25.21  Up 6d:4h:29m:50s          6c:f3:7f:cb:96:a2  BT0344052  pc-0 

MVP
Posts: 1,408
Registered: ‎05-28-2008

Re: AP not upgrading after Controller upgrade

1 -> does your port channel /LACP working as trunk to all vlans? or as access to specific vlans?

2- >does your AP looking for aruba-master or looking for an ip address of the VRRP?
*****************2Plus Wireless Solutions****************************
Aruba Airheads - Powered By community for empower the community
************ Don't Forget to Kudos + me,If i helped you******************
Occasional Contributor II
Posts: 10
Registered: ‎02-22-2011

Re: AP not upgrading after Controller upgrade

1) The controllers are layer 3 connected to two cores. The Vlans for wireless reside only in the controllers, and not on the lan.

2) Aps are looking for aruba-master

MVP
Posts: 4,269
Registered: ‎07-20-2011

Re: AP not upgrading after Controller upgrade

 

How many port-channels do you have setup in that controller ?

 

Do you have the same AP VLANs on both COREs ? 

 

Are these 6xx controllers ?

 

If you do a show ap active on the APs that are showing ?/? in the slot/port can you see if those are configured as Air Monitor or if it has any flags when you do the show ap database .

 

 

 

 

 

 

Thank you

Victor Fabian
Lead Mobility Engineer @ Integration Partners
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
MVP
Posts: 1,408
Registered: ‎05-28-2008

Re: AP not upgrading after Controller upgrade

and u have dns record that answering on requests of aruba-master? with the ip of both controllers?

*****************2Plus Wireless Solutions****************************
Aruba Airheads - Powered By community for empower the community
************ Don't Forget to Kudos + me,If i helped you******************
Occasional Contributor II
Posts: 10
Registered: ‎02-22-2011

Re: AP not upgrading after Controller upgrade

Each controller has 2 port channels.  One to each of our two core 6509.  There are no AP Vlans on the core because the Aruba controllers are running OSPF and injecting routes to the LAN. These are M6000 controllers

 

Show AP active  gives me the following.  

Name              Group          IP Address    11g Clients  11g Ch/EIRP/MaxEIRP  11a Clients  11a Ch/EIRP/MaxEIRP  AP Type  Flags  Uptime         Outer IP
----              -----          ----------    -----------  -------------------  -----------  -------------------  -------  -----  ------         --------
NO18-2N701-AP105  SusqCtrl1VRRP  10.131.36.21  0            AP:HT:11/22/22.5     0            AP:HT:48-/22/24      105      a      6d:14h:0m:22s  N/A

 

 

The dns entry for aruba-master points to one of the VRRP addressed on the  master controller.  Assuming the master is up, it should be able to set the config and what ap profile the ap should have.

~eric

 

MVP
Posts: 1,408
Registered: ‎05-28-2008

Re: AP not upgrading after Controller upgrade

[ Edited ]
  • I did a bit of reading and i watched all your earlier posts - a few times (in order to find what might cause this )
  • I really don't know to explain this behavior
  • The only thing that a bit close to your issue is this: (from 6.1.3.8 release notes)

bug.PNG

*If you would like to understand better why or how - contact Aruba TAC or SE/PNE Crew  and describe them your question and issue.,Please share the answer when u get it*

 

Me

 

 

*****************2Plus Wireless Solutions****************************
Aruba Airheads - Powered By community for empower the community
************ Don't Forget to Kudos + me,If i helped you******************
Search Airheads
Showing results for 
Search instead for 
Did you mean: