Wireless Access

Reply
Aruba
Posts: 1,285
Registered: ‎08-29-2007

APs failed over but half remain in funny state

Hi,

 

I have just had a scenario where a local controller experienced a power outage.  The APs all failed over to the Master controller, but half of them were in funny states and I can't seem to recover them.

 

The local controller came back and the (working) ones all failed back with no problems.

 

What I have is a bunch of AP stuck on the Master with a flag of 'D'.  I have issued the apboot command but they never actually reboot, leaving them stuck in this state.

 

Another bunch are showing as down, but they appear in the user-table in a logon role.  I tried a 'aaa user delete <ip>', but they just pop back in there after a few seconds.

 

All the aps have the same system profile with primary-lms being the local controller and the backup-lms being the vrrp of the master.  They are spread across different groups and there is nothing distinguishing them from the others that are working correctly.

 

Any ideas how to recover from this before I ask the customer to run around rebooting them manually.

 

Thanks


If my post is helpful please give kudos, or mark as solved if it answers your post.

ACCP, ACMP, ACMX #294
mclarke@arubanetworks.com
Aruba
Posts: 760
Registered: ‎05-31-2007

Re: APs failed over but half remain in funny state

Which AOS version?

Do you have pre-emption turned on in AP-system profile for the AP groups affected?  (so the APs can try to automatically go back to their primary LMS (local)) ? 

Aruba
Posts: 1,285
Registered: ‎08-29-2007

Re: APs failed over but half remain in funny state

6.1.2.4

 

yes, preemption enabled and half failed back to the local after it rebooted and working fine.

 

All APs have the same masterip configured


If my post is helpful please give kudos, or mark as solved if it answers your post.

ACCP, ACMP, ACMX #294
mclarke@arubanetworks.com
Aruba
Posts: 760
Registered: ‎05-31-2007

Re: APs failed over but half remain in funny state

Tks.

 

Are you running CPSEC on these controllers ?   I ask, as I have seen one other case where 'dirty' resulted from running CPSEC, and not without (root cause unknown in that case...) but worth assessing whether you are running it or not.    

 

Outside of that, I think its TAC ticket time to identify, track and resolve this issue.

 

As an aside, pls keep in mind the 6.1.2.4  release is 9 months old... you may consider upgrading it sooner rather than later, when a maintenance window comes up to benefit from a lot of other improvements to the code in a general sense. 

 

 

Aruba
Posts: 1,285
Registered: ‎08-29-2007

Re: APs failed over but half remain in funny state

cpsec is enabled as there are some sites with bridged ssids.

 

Plans are already in place for an upgrade, but that is difficult due to local controllers spread around the globe.

 

Nevertheless I am asking the customer to reboot one in each of those states to see if that resolves.

 

Thanks


If my post is helpful please give kudos, or mark as solved if it answers your post.

ACCP, ACMP, ACMX #294
mclarke@arubanetworks.com
Aruba
Posts: 760
Registered: ‎05-31-2007

Re: APs failed over but half remain in funny state

Good plan.


And good comprehensive information to have to expedite the ticket process if you go that route.

Search Airheads
Showing results for 
Search instead for 
Did you mean: