Wireless Access

Reply
Contributor I
Posts: 23
Registered: ‎02-15-2012

Android is not roaming

Hi,

 

We have an issue with Android devices and roaming. In a branch office with 8 APs users with iOS devices and Win 7 laptops can roam but android devices do not.

 

I did some tests: Remove lower transmit rates in the SSID profile, activate co-channel interface mitigation and the last test was to change 2 AP's to Air Monitor mode in order to reduce interferences. With this scenario android devices stay associated to the first AP and don't roam to another AP with a strength signal.

 

Do you know if it is an Android issue?

 

How could I fix it?

 

Thanks

Jose.

Guru Elite
Posts: 20,764
Registered: ‎03-29-2007

Re: Android is not roaming

Are these controller-based APs or IAPS?

Do you have broadcast/multicast filtering enabled on your network so that your wired clients do not degrade your wireless clients?

What version of Aruba code is it?

What encryption are you using on your wireless?

What android device and what OS is it running?

Do you have band steering turned on?

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Contributor I
Posts: 23
Registered: ‎02-15-2012

Re: Android is not roaming

Hi cjoseph,

 

The APs are controller-based, configured as RAP.

 

Broadcast/multicast is enabled in the VAP. However it's not enabled in stateful firewall. The user guide says Broadc/Mcast filtering is intended only for tunnel mode. In this case, one ssid is bridged and the another is in split-tunnel (we are testing the second). Probably the filtering is wrong configured.

 

The code version is 6.1.3.1.

The tests were done using an open ssid with captive portal (Amigopod).

The android device used is a Galaxy S with 2.3 gingerbread release.

Yes, band steering in turned on.

 

Thanks.

 

Jose

 

 

Contributor I
Posts: 23
Registered: ‎02-15-2012

Re: Android is not roaming

Sorry, I mean that drop broadcast/multicast is enabled int the vap (d = Drop Mcast/Bcast On)

Contributor I
Posts: 23
Registered: ‎02-15-2012

Re: Android is not roaming

..and there is no wired clients sharing the vlan associated to this SSID.

Guru Elite
Posts: 20,764
Registered: ‎03-29-2007

Re: Android is not roaming

J8888,

 

You have it correct.  All you should need is drop broadcast/multicast in the VAP.

 

Since it is android clients on Gingerbread, it is probably the drivers in those older devices that you cannot do anything about

 

You can try the local-probe-response-threshold setting in the Advanced Tab of the SSID profile.  Start by setting it at 30 and test with Androids as well as non-android devices.

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Contributor I
Posts: 23
Registered: ‎02-15-2012

Re: Android is not roaming

Hi cjoseph,

 

I will test it. Many thanks.

Jose.

Search Airheads
Showing results for 
Search instead for 
Did you mean: