Wireless Access

Reply
Occasional Contributor I
Posts: 6
Registered: ‎02-29-2012

ArubaOS 6.0.2.1 bugs?

Dear all,

 

My Aruba Controller using ArubaOS 6.0.2.1 , after i add the following command:

 

(host)(config) # aaa xml-api server 10.12.13.14

(host) (XML API Server "10.12.13.14") # key arubaxml

 

 

(host)(config) # aaa profile wirelessuser

(host)(AAA Profile "wirelessuser") # xml-api-server 10.12.13.14

(host)(XML API Server "10.12.13.14") # key arubaxml

 

The Aruba Controller could not to provide services normally. (e.g. User cannot access the Captive Portal server)

Do i need to reload/reboot the Aruba Controller?

Aruba Employee
Posts: 100
Registered: ‎12-02-2011

Re: ArubaOS 6.0.2.1 bugs?

Can you please put the config of your captive portal profile and intial user-role (ACL)?

Occasional Contributor I
Posts: 6
Registered: ‎02-29-2012

Re: ArubaOS 6.0.2.1 bugs?

Dear all,

 

Before I add xml-api command:

!
aaa profile "AAA_CAPTIVE_PORTAL"
   initial-role "guest-logon-test"
   xml-api-server "10.12.13.100"
!

!
user-role guest-logon-test
 captive-portal "captiveportal"
 access-list session allowall

!

!
aaa authentication captive-portal "captiveportal"
   server-group "internal"
   protocol-http
   logon-wait cpu-threshold 95
   login-page "http://macau123.mo/captiveportal"
   no enable-welcome-page
   switchip-in-redirection-url
!

 

 

 

 

 

After I add xml-api command:

!
aaa xml-api server "10.12.13.14"                  <============ new add command
   key 718424a3e1105543cb22432da34
!

!
aaa profile "AAA_CAPTIVE_PORTAL"
   initial-role "guest-logon-test"

   xml-api-server "10.12.13.14"  <======= new add command
   xml-api-server "10.12.13.100"
!

!
user-role guest-logon-test
 captive-portal "captiveportal"
 access-list session allowall

!

!
aaa authentication captive-portal "captiveportal"
   server-group "internal"
   protocol-http
   logon-wait cpu-threshold 95
   login-page "http://macau123.mo/captiveportal"
   no enable-welcome-page
   switchip-in-redirection-url
!

 

 

 

 

After I add these command , do I need to reload/reboot the Aruba Controller?

 

Guru Elite
Posts: 20,768
Registered: ‎03-29-2007

Re: ArubaOS 6.0.2.1 bugs?

You should not have to reload.  Can your clients resolve dns?

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Aruba Employee
Posts: 100
Registered: ‎12-02-2011

Re: ArubaOS 6.0.2.1 bugs?

Just wondering, did you allow acceess to your external erver ip in the captive portal ACL?

 

By default Captive Portal ACL will not allow any HTTP/HTTPs traffic to go through and will dsn-nat it to port 8080 or 8081. In case of exernal captive portal, you need to put ACL in the top to allow HTTP/HTTPs traffic to your external web-server.

 

Please go through the KB article answer id -124 and make sure config is correct.

 

http://support.arubanetworks.com/Default.aspx?tabid=111&loc=https://kb.arubanetworks.com/cgi-bin/arubanetworks.cfg/php/enduser/std_alp.php?p_sid=g_xs7ZRk

Occasional Contributor I
Posts: 6
Registered: ‎02-29-2012

Re: ArubaOS 6.0.2.1 bugs?

Dear cjoseph and aalap2,

 

Before I add the xml-api command, the Aruba Controller working fine.

After I add the xml-api command, some problem appear (e.g. client users cannot resolve DNS, cannot access captive portal server).

Search Airheads
Showing results for 
Search instead for 
Did you mean: