Wireless Access

Reply
Occasional Contributor II
Posts: 19
Registered: ‎05-08-2013

Cant ping next hop IP using switch as default gateway

I have an S2500-48P with 3 VLANS on it. VLAN 1(IP 192.168.1.254/24), VLAN 2(IP 192.168.3.254/23), VLAN 3(IP 192.168.5.254/23). I am using the switch as the default gateway for all the clients Traffic is then NAT'ed on a cisco router with LAN IP 192.168.1.252. I se the default gateway of the switch to 192.168.1.252. When I do a show ip route I see the following

 

0.0.0.0 0.0.0.0 via 192.168.1.252

192.168.1.0/24 connected on VLAN 1

192.168.1.254/32 connected on VLAN 1

192.168.2.0/23 connected on VLAN 2

192.168.3.254/32 connected on VLAN 2

192.168.4.0/23 connected on VLAN 3

192.168.5.254/32 connected on VLAN 3

 

Client 1 (IP 192.168.1.251 subnet 255.255.255.0 DG 192.168.1.254)

Client 2 (IP 192.168.3.251 subnet 255.255.254.0 DG 192.168.3.254)

Client 3 (IP 192.168.5.251 subnet 255.255.254.0 DG 192.168.5.254)

 

Client 1 can pin the next hop (192.168.1.252) and can ping client 2 and 3.

Client 2 and 3 can ping each other and can ping VLAN 1 switch IP (192.168.1.254) but cant ping next hop (192.168.1.252). 

Valued Contributor II
Posts: 804
Registered: ‎12-01-2014

Re: Cant ping next hop IP using switch as default gateway

Hi Friend,

 

Can you share some more information ? such as,

 

1. L3 config of VLANs , "show ip interface brief"

2. NAT config. "show interface vlan <id>"

3. Routing table of the cisco router, "show ip route"

 

Please comeback with the above info, I will surely help you to fix the issue.

 

 

Cheers,
Venu Puduchery,
[Is my post helped you ? Give Kudos :) ]
Occasional Contributor II
Posts: 19
Registered: ‎05-08-2013

Re: Cant ping next hop IP using switch as default gateway

I have had to add a few more vlans but the essentials are the same. Herewith the following 

 

1) Show IP interface brief

Flags: S - Secondary IP address

Probe: U - Up, D - Down, U/O - Up & Own IP, N/A - Not Applicable

Interface                   IP Address / IP Netmask        Admin   Protocol Probe  Flags

vlan 1                   192.168.1.254 / 255.255.254.0     Up      Up       N/A           

vlan 10                 192.168.19.254 / 255.255.254.0     Up      Up       N/A           

vlan 12                 192.168.23.254 / 255.255.254.0     Up      Up       N/A           

vlan 13                 192.168.25.254 / 255.255.254.0     Up      Up       N/A           

vlan 14                 192.168.27.254 / 255.255.254.0     Up      Up       N/A           

vlan 2                   192.168.3.254 / 255.255.254.0     Up      Up       N/A           

vlan 20                 192.168.39.254 / 255.255.254.0     Up      Up       N/A           

vlan 3                   192.168.5.254 / 255.255.254.0     Up      Up       N/A           

vlan 300                    unassigned / unassigned        Up      Up       N/A 

vlan 5                   192.168.9.254 / 255.255.254.0     Up      Up       N/A           

vlan 7                  192.168.13.254 / 255.255.254.0     Up      Up       N/A           

vlan 8                  192.168.15.254 / 255.255.254.0     Up      Up       N/A           

vlan 9                  192.168.17.254 / 255.255.254.0     Up      Up       N/A           

mgmt                        unassigned / unassigned        Up      Down     N/A 

 

2 ) I am not doing any NAT on the switch.

 

3) Cisco config is as below

interface GigabitEthernet0/0

description To-LAN-network

ip address 192.168.1.252 255.255.0.0

ip nat inside

ip virtual-reassembly in

load-interval 30

duplex auto

speed auto

no cdp enable

!

interface GigabitEthernet0/1

description To-ISP-router

ip address 41.xxx.xx.xx 255.255.255.248

ip nat outside

ip virtual-reassembly in

load-interval 30

duplex auto

speed auto

no cdp enable

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip nat inside source list 1 interface GigabitEthernet0/1 overload

ip nat inside source static tcp 192.168.2.253 80 41.xxx.xx.xx 80 extendable

ip nat inside source static tcp 192.168.2.236 80 41.xxx.xx.xx 1236 extendable

ip nat inside source static tcp 192.168.2.237 80 41.xxx.xx.xx 1237 extendable

ip nat inside source static tcp 192.168.2.238 80 41.xxx.xx.xx 1238 extendable

ip nat inside source static tcp 192.168.2.239 80 41.xxx.xx.xx 1239 extendable

ip nat inside source static tcp 192.168.2.240 80 41.xxx.xx.xx 1240 extendable

ip nat inside source static tcp 192.168.2.241 80 41.xxx.xx.xx 1241 extendable

ip nat inside source static tcp 192.168.2.8 22 41.xxx.xx.xx 2222 extendable

ip nat inside source static tcp 192.168.2.253 8080 41.xxx.xx.xx 8080 extendable

ip nat inside source static tcp 192.168.1.250 8181 41.xxx.xx.xx 8181 extendable

ip nat inside source static tcp 192.168.1.250 22 41.xxx.xx.xx 8282 extendable

ip nat inside source static tcp 192.168.2.8 80 41.xxx.xx.xx 8888 extendable

ip nat inside source static tcp 192.168.2.8 10000 41.xxx.xx.xx 10000 extendable

ip route 0.0.0.0 0.0.0.0 41.190.46.49

!

access-list 1 permit 192.168.0.0 0.0.255.255

 

Valued Contributor II
Posts: 804
Registered: ‎12-01-2014

Re: Cant ping next hop IP using switch as default gateway

HI,

 

As per the information given, Routing table and the VLAN interface info are not matching.

as per the VLAN interface :

 

VLAN 1 : 192.168.1.0 /23

VLAN 2 : 192.168.3.0 /23

VLAN 3 : 192.168.5.0 /23

 

rt2.JPG

 

As per the routing table of the switch :

 

VLAN 1 : 192.168.1.0 /24

VLAN 2 : 192.168.2.0 /23

VLAN 3 : 192.168.4.0 /23

 

RT1.JPG

 

Here my point is, why VLAN 1 subnet is populated as /24  in the routing table ? and summarised routes of VLAN 2 and 3 are showing different ?

 

if you made some changes after showing the routing table please share the current routing table

 

Please feel free to come back on this

Cheers,
Venu Puduchery,
[Is my post helped you ? Give Kudos :) ]
Occasional Contributor II
Posts: 19
Registered: ‎05-08-2013

Re: Cant ping next hop IP using switch as default gateway

Thanks for all the help. Turns out that the NAT router which is controller by the ISP didnt have the correct routes on it. SO got them to add the routes for the rest of the subnets and we are all up and running.

 

Thanks again for the help

Search Airheads
Showing results for 
Search instead for 
Did you mean: