Wireless Access

Reply
Contributor I
Posts: 26
Registered: ‎11-15-2013

Captive Portal - Always load login page with mobile devices

We are running 6.4.2.12 on our 7210 controllers.  We have a captive portal page that works for what we need it for.  In regards to connecting to the guest network, if the user has no browser already loaded on their mobile device and when they open (ex: safari) it will load the login page.  However, if a user already has safari opened, connects to the guest network, opens safari again, it does not redirect them automatically to the login page.  They would have to go to another website before the login page loads.

Aruba Employee
Posts: 10
Registered: ‎11-13-2012

Re: Captive Portal - Always load login page with mobile devices

This may be expected behavior if I understand the issue right.  I understand this is your issue: if a guest client connects to the guest network and Safari isn't open, when they open Safari the login pag loads, but if Safari was already open and a new window is opened the login page doesn't load until a URL is entered.  What I suspect is happening is that when Safari is already opened and a new window or tab is opened this isn't triggering the browser to load the homepage but instead just a blank screen is displayed.  However when Safari wasn't already opened when a new webpage is started this triggers the client to navigate to the homepage.  In order for captive portal to work properly we need the wireless client to attempt to access a website so we can capture the response from the webserver which we use to send a redirect to the client.  So this may be expected behavior based on client behavior as to when it decides to open the home page versus a blank page when the browser already has an open window.  When you bring up the browser on the client does it attempt to reach the home page or does it display a blank screen?

Search Airheads
Showing results for 
Search instead for 
Did you mean: