Wireless Access

Reply
Occasional Contributor II
Posts: 18
Registered: ‎06-19-2014

Captive portal access denied

Hi Guys,

 

I have a network composed of some Remote APs. We have an external radius and captive portal server, however when the user tries to authenticate here is what happen:

1-The user associates with the SSID and is redirected to the captive portal

2-The user enters his credentials

3- The user is redirected to either a blank page (chrome), an http404 (Edge) or the error message "This page isn't redirected properly" (Firefox). The URL always shows https://controllers'URL/cgi-bin/login?xxxAccessDeniedxxxxxxxxx.

 

I checked the logs and noticed the following when testing using Microsoft Edge "httpd: [cgid:error] [pid 15224:tid 841479344] [client IPofthe client:50766] AH01265: attempt to invoke directory as script: /mswitch/apache/cgi-bin/, referer: https://URL-of-the-captive-portal?cmd=login&mac=08:d4:0c:d4:82:8a&ip=172.16.0.210&essid=WLAN-NameA&apname=AP-NAMEac&apgroup=AP-Group&url=http%3A%2F%2Fcnn.com%2F"

 

The user-table shows the user in the logon role. I also tested using Tunnel mode and Split-Tunnel but no luck with both

 

I also captured the radius traffic and saw that the controller does not send the radius request to the radius server at all to validate the user credentials

 

Any help would be highly appreciated guys

Guru Elite
Posts: 20,994
Registered: ‎03-29-2007

Re: Captive portal access denied

Is this external or internal captive portal?


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Occasional Contributor II
Posts: 18
Registered: ‎06-19-2014

Re: Captive portal access denied

Hi Joseph

it is an external captive portal server

Search Airheads
Showing results for 
Search instead for 
Did you mean: