Wireless Access

Reply
Frequent Contributor II

Captive portal page is not coming in laptop

Hi All,

I am facing some weird issue.

I have configured captive portal with 802.1x, so 1st user has to complete 802.1x auth the web authentication.

The set up was working fine but suddenly stopped working.

But I am still able to get CP page in mobile device and if i type 1.1.1.1 in laptop getting the page but with www.google.com nothing is coming..

Any clue why this is happening.

I ma using controller internal cp page.

rana
Guru Elite

Re: Captive portal page is not coming in laptop

Does DNS resolution work after completing 802.1x?


Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Frequent Contributor II

Re: Captive portal page is not coming in laptop

yeah its should work because i'M using google public DNS.

and also the setup is still working fine with mobile devices [android, IOs]

rana
Aruba Employee

Re: Captive portal page is not coming in laptop

Hi Rana,

 

Are you using a Cisco WLC? Or is this for AOS. The two handle captive portal redirects differently.

 

If it is a Cisco WLC, did you just recently upgrade code on it?

 

Thanks,

Zach Jennings
Frequent Contributor II

Re: Captive portal page is not coming in laptop

No, I am using AOS only.

rana
Guru Elite

Re: Captive portal page is not coming in laptop

Rana,

 

Does nslookup work when the laptop has this issue?  If it works for 1.1.1.1 but not for web pages, that points to DNS lookups not working.

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Frequent Contributor II

Re: Captive portal page is not coming in laptop

Thanks Colin,

I checked, nslookup is working.

Even the total set up is working fine with mobile devices. A

rana
Guru Elite

Re: Captive portal page is not coming in laptop

Rana,

 

Does that laptop have a proxy configured?



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Re: Captive portal page is not coming in laptop

this is crazy thinking but have you tried a non-https site? Which browser are you using on the laptop? Does it work when you use IE? Does it not work when you use Chrome/Firefox?
Are you using the controllers certificate or did you install your own?
Pasquale Monardo | Senior Network Solutions Consultant
ACDX #420 | ACMP
[If you found my post helpful, please give kudos!]
Frequent Contributor II

Re: Captive portal page is not coming in laptop

Thank you all, I got the issue resolved.

When I looked in datapath session table Y flag was coming, so I checked in firewall and saw that firewall was dropping the traffic for guest.

But I can not understand how that works with mobile device.. is there any difference between mobile traffic and laptop traffic for captive portal.

rana
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: