Wireless Access

Reply
New Contributor

Captive portal timeout issues

I hate to post this, but I'm new to WLAN configuration so I'm trying to find where to start.(Not new to general network config)

 

I have an Aruba 650 controller configured for guest access via the built in Aruba captive portal, all is working OK with one exception.  Users note that when they lose connection(leave building, sleep device, etc), they always have to re-do the captive portal login.  Is there any way to have sessions last longer when using the built in guest access?

 

As an example, I have a user reporting that if they walk outside far enough for signal to drop to 0, then return into the building less than a minute or 2 later, they have to go through the disclaimer page again.

 

Any leads on troubleshooting would be appreciated.

Aruba

Re: Captive portal timeout issues

Users should remain 'authenticated' for the duration of the timeout set under: 


Configuration/Authentication/Advanced 

 

Under this screen you have the ability to set various timeout values.    You will want to 'bump up'  "user idle timeout" to reduce the number of times the captive portal pops-up to the users.

 

I would look at what its currently at and then set for something manageable (say 15 minutes) initially to see how the user community experience improves.

New Contributor

Re: Captive portal timeout issues

Does anyone know where to find this setting on the 3200 controller? We are having exactly t he same issues. As soon as a user disconnects or connects to another network, then back again, they have to re-authenticate.

 

Thanks

Aruba Employee

Re: Captive portal timeout issues

Try:

Screen Shot 2012-01-11 at 6.21.54 AM.jpg


Harold
New Contributor

Re: Captive portal timeout issues

Nice 1. Thanks

Frequent Contributor I

Re: Captive portal timeout issues

Hi 

 

Is there a way to change the idle timeout value to a greater value than 5 minutes?

Re: Captive portal timeout issues

All you should have to do, is change the value in the option in the previous screenshot to something greater. The most you can set is 15300 seconds (or about 4.5 hours).

 

I noticed some v6 versions have a bug in the gui where it asks you "interim stats" even though you didn't ask or need to. To get around this, I'd telnet/ssh into the controller and do "aaa timers idle-timeout X seconds" from config mode. This work fine. I'd recommend not setting this too high on busy controllers, or you'll start burdening them with lots of legacy session information about transient devices.

 

However, one additional tip... I saw exactly what your seeing for quite a few customers. I also found that setting the dos prevention feature under the relevant VAP helped. Why? Well a lot of client devices send a disassociate message when going to sleep or whatever. When they do, this tells the controller they've gone and the user session is booted out anyway (regardless of timers). To fix, enabling dos-prevention tells the controller not to pay attention to the dis-associate message from the device. Try it out.

 

wlan virtual-ap "default"

 dos-prevention

Kudos appreciated, but I'm not hunting! (ACMX 104)
Retired Employee

Re: Captive portal timeout issues

Following are the commands to increase the user-idle timeout 

 

Current timers: 

(master) #show aaa timers

User idle timeout = 300 seconds
Auth Server dead time = 10 minutes
Logon user lifetime = 5 minutes
User Interim stats frequency = 600 seconds

 

Set the user-idle timeout to 10 minutes. 

(master) (config) #aaa timers idle-timeout 600 seconds

 

(master) (config) #show aaa timers

 

User idle timeout = 600 seconds
Auth Server dead time = 10 minutes
Logon user lifetime = 5 minutes
User Interim stats frequency = 600 seconds

--
HT
New Contributor

Re: Captive portal timeout issues

hello Everyone,

 

I have depolyed 7210 Aruba Controller with captive portal service, IPhones are having issue with Portal pages, the portal page suddenly disappear and user is disconnected from the network, i tried many things  but none of the soultion was permanant and its happening again and again, if anyone could advise how to resolve issue.

 

Regards

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: