Wireless Access

Reply
Regular Contributor I
Posts: 191
Registered: ‎03-22-2013

DHCP Option 43 and 60 appear to be breaking bootp printers

Since I enabled these options to facilitate the migration of APs onto new controllers, we have recently had reports of printers that stop working.  We are seeing the error bad bootp tagsize on the printers.

 

We have tested this by removing 43 and 60 from a scope, and rebooting the printer, and it works again. 

 

Anyone encountered this?

 

 

Contributor II
Posts: 57
Registered: ‎12-10-2011

Re: DHCP Option 43 and 60 appear to be breaking bootp printers

 

 

Option 60 & 43 are usually ingored by devices if they don't make sense to them.

 

But, since printer is complaining abbout bootup size, Can you confirm if you replaces these options (43 &60) with some other dummy options, if printer still sees the issue.

 

 - What i am trying to understand is that, is issue restricted only to 43,60 options or adding any other options (increased size) to your DHCP scope causes this.

 

Thanks,

-Vinay

Regular Contributor I
Posts: 191
Registered: ‎03-22-2013

Re: DHCP Option 43 and 60 appear to be breaking bootp printers

We do have some other options enabled, so perhaps adding 43 & 60 tipped things over... 

 

We did wonder if bootp works differently from dhcp, and may just have been receiving all of the additional lease info...  Ive had to remove these options for now, and come up with a workaround.. Its nothing major, its just forced my hand a little to complete the migration.  Just at first, we didnt think anything of it, as I had first enabled these options over a month ago, and we have only just started seeing these issues.  Leases usually expire after a d ay or 2, so we would have expected this to happen sooner, however, all of these printers do have reservations, so perhaps this invokes a longer waiting time.

 

What I did notice when I started this, was that I tried to change option 43 at the root/global level, but it wouldnt accept an IP address, only about 4 digits, so I had to manually configure these options per scope.

 

 

Search Airheads
Showing results for 
Search instead for 
Did you mean: