Wireless Access

Reply
Aruba Employee
Posts: 19
Registered: ‎11-10-2015

DNS not working from controller CLI

I have a pair of 7220 controllers that are performing local controller functions at a large campus.  Both controllers are configured with name servers and have ip domain lookup enabled.  They also both have the same default route.  However, the secondary controller can resolve DNS correctly (tested via the ping www.cnn.com command) but the primary controller cannot.  When testing using the ping command and a name, I get the following response:

#ping www.cnn.com
Incorrect input! Use 'ping <target-ip-address>'

 

Any ideas on how to get DNS working?  This is preventing our BLE beacons from talking through the controller correctly.  Thank you.

Guru Elite
Posts: 21,010
Registered: ‎03-29-2007

Re: DNS not working from controller CLI

What version of ArubaOS is this?

 

How are the beacons involved?



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Aruba Employee
Posts: 19
Registered: ‎11-10-2015

Re: DNS not working from controller CLI

This is 6.4.4.2.

The beacons have a URL in the system profile that currently isn't resolvable as DNS isn't functioning (not as far as I can tell).  In Meridian, I can see the beacons only talk to MEridian through my beacons app, not through the controller.

Guru Elite
Posts: 21,010
Registered: ‎03-29-2007

Re: DNS not working from controller CLI

ip domain lookup could require a controller reboot:

 

(Aruba7005-US) #configure t
Enter Configuration commands, one per line. End with CNTL/Z

(Aruba7640-US) (config) #ip domain?     
domain                  IP DNS Resolver
domain-name             Define the default domain name

(Aruba7640-US) (config) #ip domain ?
lookup                  Enable IP Domain Name System hostname translation 
                        for clients

(Aruba7640-US) (config) #ip domain lookup 
Operation may not take effect until a reboot

 

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Aruba Employee
Posts: 19
Registered: ‎11-10-2015

Re: DNS not working from controller CLI

I will try and reboot off hours to see if this resolves.  However, both controllers were configured with the same settings (name-servers and ip domain lookup) and neither were rebooted, yet the secondary resolves successfully and the primary doesn't.  

 

Again, will reboot and let you know.

Search Airheads
Showing results for 
Search instead for 
Did you mean: