Wireless Access

Reply
Contributor I

Deleted rule from firewall reappearing!

Deleting a rule from firewall policy, clicking done, then apply, at whcih point it is returning me to the User Roles screen.. If I then go back in, the rule is there again!

 

Ive tried various combinaitons of saving, applying etc.. but it always comes back...

 

Can I do this via cli as a workaround?

 

 

Guru Elite

Re: Deleted rule from firewall reappearing!

What version of code?  Before clicking "Apply" click on "show commands" to see what command it is trying to execute.  It might be a bug...

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Contributor I

Re: Deleted rule from firewall reappearing!

v5049

 

It seems to be showing the right command.. but obviously  not executing it!  Maybe ill try via ssh... 

 

Doesnt seem to work via ssh either....  I can see the access list session including the rule I want to delte, but when I try to do this I get "unknown policy"

 

Driving me nuts.. what a wast of a morning!!!

 

 

 

 

Guru Elite

Re: Deleted rule from firewall reappearing!

If you just upgraded your controller, try clearing the browser cache".

 

In addition, go to the commandline and type "show audit-trail" to see if the command was executed at all.

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Contributor I

Re: Deleted rule from firewall reappearing!

Had a look at audit trail, and it seems it isnt being executed!??

 

ip access-list session "captiveportal" no any host 17.0.0.0 "255.0.0.0" permit > -- command execution failed

 

If I look at the command section in gui.. its try to do:

no any host 17.0.0.0 255.0.0.0 any permit

 

Yet the "any" part of this doesnt seem to be an option when I view the help menu whilst manually entering the code... so I try permit, and get "unknown policy"

Guru Elite

Re: Deleted rule from firewall reappearing!

Then that is a bug.  What version of ArubaOS?

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Contributor I

Re: Deleted rule from firewall reappearing!

v5049  -  the latest we can upgrade to due to hardware limitaitons.

 

Thanks for you help!  

Guru Elite

Re: Deleted rule from firewall reappearing!

Did you try clearing the browser cache or using a different browser?

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Contributor I

Re: Deleted rule from firewall reappearing!

Tried both....

 

Seems that when I look at the commands lst in the gui it is also trying to execute commands I havent asked it to.. which is a little worrying.. and prob best it isnt actually doing them!

 

Think Ill be logging a call!

Frequent Contributor II

Re: Deleted rule from firewall reappearing!

I have had this loads of time with the GUI. Personally, CLI is the only way to be sure. I think you are very wise up validate your config changes the way you have. It may sound overkill but checking in your configurations into a repository so you can diff the configs is a good 'workaround' for this behaviour.
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: