Wireless Access

Reply
Frequent Contributor I

EoGRE Tunnel Between Aruba Controller and CISCO SaMOG

 Hi All,

 

I am going to implement L3 EoGRE Tunnel between our Aruba Controller and cisco SaMOG. The issue is, the tunnel is not going UP. When i run a command "show interface tunnel 1" controller shows me "Tunnel 1 is UP, line protocol is down".

 

Below are my configuration on controller.

 

Vlan 490

 

interface Tunnel 1
  tunnel mode gre 1

  ip address 10.195.13.132 255.255.255.224
  tunnel Keepalive
  tunnel source Vlan 490
  tunnel destination 10.195.64.129

exit

 

The above tunnel IP is from VLAN 490.

Please help me out if i am doing any mistake in configuration.

 

Aruba Employee

Re: EoGRE Tunnel Between Aruba Controller and CISCO SaMOG

Can you please try to send us the configuration at cisco side?

Rabih Itani
Frequent Contributor I

Re: EoGRE Tunnel Between Aruba Controller and CISCO SaMOG

Thanks for your reply.

 

CISCO SaMOG is ASR6500 Device. The CISCO device is not under our control and as per cisco team they have no stataic configuration for GRE. This device (SaMOG) create tunnel dynamically mean to say SaMOG create tunnel to any device from which he receive request for GRE tunnel. 

Contributor II

Re: EoGRE Tunnel Between Aruba Controller and CISCO SaMOG

I doubt this information. Can you recheck with them?

 

Below is from Cisco docmentation for IPoGRE on SaMOG:

     interface  interface_tunnel_name tunnel
          ip vrf forwarding  gre_vrf_name
          ip address  ip_address[/mask ]ipv4/v6_address
          tunnel-mode gre
               source interface interface_name
               destination address ipv4_address
               exit 
          exit 

Reference:

https://www.cisco.com/c/en/us/td/docs/wireless/asr_5000/20/SaMOG/b_20-SaMOG-Admin/b_20-SaMOG-Admin_chapter_0101.html#reference_5873e7a4-0843-4001-989d-3d2ffe828e68

JayBee
ACDX | CCIE (RnS/SP,DC) | ACCP | ACMP | ACMA | JNCIS | JNCIA
If the provided solution resolves your issue, please mark it as accepted solution to help others.
Aruba Employee

Re: EoGRE Tunnel Between Aruba Controller and CISCO SaMOG

the tunnel type is configured as "tunnel mode gre 1” and this means this is L2 GRE tunnel. For L3 GRE, this should be “tunnel mode gre ip”

 

This is a sample config for L3 GRE, between two Aruba controllers.

 

IPv4 Controller-1 Configuration

(Controller-1) (config) # interface tunnel 104

description “IPv4 L3 GRE 104"

tunnel mode gre ip

ip address 1.1.1.1 255.255.255.255

tunnel source vlan 10

tunnel destination 20.20.20.249

Trusted

 

IPv4 Controller-2 Configuration

(Controller-2) (config) # interface tunnel 204

description “IPv4 L3 GRE 204"

tunnel mode gre ip

ip address 1.1.1.2 255.255.255.255

tunnel source vlan 20

tunnel destination 10.10.10.249

Trusted

Rabih Itani
Aruba Employee

Re: EoGRE Tunnel Between Aruba Controller and CISCO SaMOG

Hello, can you please update us on the status?

Rabih Itani
Frequent Contributor I

Re: EoGRE Tunnel Between Aruba Controller and CISCO SaMOG

Hi,

 

The issue is still not resolved. Aruba TAC and local system engineer are working with us. We tried both L2 and L3 gre but nothing happened. whenever we disable the keepalive, the tunnel goes up. We are troubleshooting the issue with Cisco.

Aruba Employee

Re: EoGRE Tunnel Between Aruba Controller and CISCO SaMOG

Can we conifigure or set Protocol Type to 6558 as cisco is WLC is configured?

 

 

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: