Wireless Access

Reply
New Contributor

Error: "perl: warning: Setting locale failed."

Hi,

 

We recently installed Airwave 7-3-5. Yesterday I logged on to the cli to do an upgrade and noticed this:

 

Last login: Mon Feb 20 15:25:40 2012 from XXXXXXX
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "UTF-8",
LANG = "en_US"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "UTF-8",
LANG = "en_US"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
svn: warning: cannot set LC_CTYPE locale
svn: warning: environment variable LC_CTYPE is UTF-8
svn: warning: please check that your locale name is correct
SVN Root: http://svn.corp.airwave.com/usr/local/svnroot/mercury/tags/RELEASE_7_3_5

Daemons:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "UTF-8",
LANG = "en_US"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
UID PID PPID PGID C STIME TT TIME CMD
0 4197 1 4197 0 2011 ? 01:29:20 airbus
0 3990 1 3990 0 2011 ? 00:02:02 httpd_
0 4193 1 4193 1 2011 ? 20:31:58 Daemon::ServiceWatcher
0 4199 1 4199 0 2011 ? 00:00:17 Daemon::TupleSpaces
0 4202 1 4202 0 2011 ? 05:07:42 Daemon::TupleScheduler
0 4205 1 4205 0 2011 ? 00:01:29 Daemon::SwarmHandler
0 4222 1 4222 0 2011 ? 00:07:38 Daemon::AlertD
0 4225 1 4225 0 2011 ? 07:58:50 Daemon::APListCacher
0 4228 1 4228 0 2011 ? 00:07:03 Daemon::APScanner
0 4231 1 4231 0 2011 ? 01:02:09 Daemon::APWatcher
0 4234 1 4234 0 2011 ? 00:00:00 Daemon::APWatcherPollNow
0 4237 1 4237 4 2011 ? 2-06:22:41 Daemon::AsyncLoggerClient
0 4244 1 4244 0 2011 ? 00:11:03 Daemon::ConfigPusher
0 4250 1 4250 0 2011 ? 00:25:52 Daemon::ConfigVerifier
0 4256 1 4256 0 2011 ? 00:18:49 Daemon::DeviceEvent
0 4260 1 4260 0 2011 ? 00:17:55 Daemon::DNSFetcher
0 4282 1 4282 0 2011 ? 00:00:00 Daemon::PartialConfigPusher
0 4285 1 4285 0 2011 ? 00:00:00 Daemon::PAPI
0 4327 1 4327 0 2011 ? 04:05:26 Daemon::SNMPEnabler
0 4329 1 4329 0 2011 ? 00:02:35 Daemon::SNMPFetcher
0 4340 1 4340 0 2011 ? 05:19:09 Daemon::SNMPV2Fetcher
0 4342 1 4342 0 2011 ? 00:16:56 Daemon::SNMPV2Fetcher
0 4346 1 4346 0 2011 ? 03:04:25 Daemon::SyncD
0 4355 1 4355 0 2011 ? 03:59:14 Daemon::WepKeySetter
0 4396 1 4396 4 2011 ? 2-06:59:44 Daemon::AsyncLoggerClient
0 16404 1 16404 0 Feb12 ? 00:32:46 Daemon::PerfCollector
102 4357 1 4356 10 2011 ? 5-20:26:49 VisualRF
0 4173 1 4173 0 2011 ? 09:29:35 Daemon::LowLevelServiceWatcher
0 4208 1 4193 0 2011 ? 00:00:00 msgHandler
101 4216 1 4216 0 2011 ? 00:00:00 pound
101 4217 4216 4216 0 2011 ? 00:22:53 pound
95 4318 1 4318 0 2011 ? 00:02:19 radiusd
48 3674 1 3674 0 2011 ? 00:16:21 rrdcached
0 4337 1 4337 0 2011 ? 04:51:10 snmptrapd
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "UTF-8",
LANG = "en_US"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Current Version: RELEASE_7_3_5
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "UTF-8",
LANG = "en_US"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
svn: warning: cannot set LC_CTYPE locale
svn: warning: environment variable LC_CTYPE is UTF-8
svn: warning: please check that your locale name is correct
[root@XXXXXX mercury]#

 

Anyone now how I can fix this?

 

Thanks,

 

Mark

Regular Contributor I

Re: Error: "perl: warning: Setting locale failed."

What is your locale set to? 

 

This KB article may help you solve the problem:

http://na2.salesforce.com/_ui/selfservice/pkb/PublicKnowledgeSolution/d?orgId=00D3000000008G4&id=50140000000Mf6j&retURL=%2Fsol%2Fpublic%2Fsolutionbrowser.jsp%3Fsearch%3Dlocale%26cid%3D000000000000000%26orgId%3D00D3000000008G4%26t%3D4&ps=1

 

How do I set a local time zone for AWMS / AMP?
 
To set a local time zone for AWMS / AMP, use the following command:

cp /usr/share/zoneinfo/[REGION]/[LOCALE] /etc/localtime

where [REGION] is one of the directories under /usr/share/zoneinfo/ and [LOCALE] is the desired time zone file under that directory. You will be overwriting the file /etc/localtime with the desired locale file.

Run the 'date' command to check the results.

Note that this command merely copies the current file; if the server's time zone changes, the file would need to be copied again. Linking the file via a standard symlink will not work in some circumstances due to a problem with the CPAN 'datetime' module not respecting symbolic links. AirWave is in the process of notifying the CPAN maintainer regarding the symlink problem and will update the datetime CPAN module if and when a new version becomes available.
New Contributor

Re: Error: "perl: warning: Setting locale failed."

Aruba Techsupport has fixed it. I'm not sure what they did, it wasn't easy it took them a few hours of investigation the issue.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: