Wireless Access

Reply
Occasional Contributor I
Posts: 7
Registered: ‎03-19-2009

Guest users from local controller not redirecting to captive portal

I have a setup usiing mater / local enviorment where guest user's traffic comes only into master controller and then redirect to captive portal (clearpass) for self register/logon process.

 

This works well for users on master controller, but not from local controllers. Users are getting DHCP and they can resolve DSN as well. But they failed to redirect to captive portal and times out when open a web browser. 

 

DHCP server for guest is on master controler. GRE tunnel created to port guest traffic from local controller and spitting into guest VLAN.  GRE tunnel trusted on local side and untrusted at master side.

 

config extract as below

 

Local Controllre

 

interface tunnel 101
description "Tunnel Interface"
tunnel source loopback
tunnel mode gre 0
tunnel destination 10.99.40.99
trusted
mtu 1500
tunnel vlan 32

 

 

Master Controller 

 

interface tunnel 101
description "Tunnel Interface"
tunnel source loopback
tunnel mode gre 0
tunnel destination 10.99.30.99
mtu 1500
tunnel vlan 32

 

 

Thanks inadvance

Aruba
Posts: 1,643
Registered: ‎04-13-2009

Re: Guest users from local controller not redirecting to captive portal

Does the local controller have an IP on the client VLAN? It is required for captive portal redirects.
------------------------------------------------
Systems Engineer, Northeast USA
ACCX | ACDX | ACMX

Occasional Contributor I
Posts: 7
Registered: ‎03-19-2009

Re: Guest users from local controller not redirecting to captive portal

[ Edited ]

Thanks heaps,  adding IP address to client vlan on local controller solve the issue. 

 

Since client vlan on local bridged to client vlan on master via L2 GRE tunnel, I didn't see any requirement for IP address on local side.

 

Cheers

Search Airheads
Showing results for 
Search instead for 
Did you mean: