Wireless Access

Reply
Regular Contributor I

HUAWEI E353 don´t work with RAP 3wn

Hello community,

 

we´ve a RAP3wn and wie want to set the Uplink to 3g.

Ok, we bought the Huawei e353 USB modem witch is on the supported list.

Capture.JPG

 

The RAP comes up as an instant. I goes to Settings, and change the settings to Germany and vodafone, then I restart the RAP.

When the RAP is up again I changed it to an Remote AP.

But the USB Modem doesn´t work, it can´t connect to the controller.

 

When I put the eth 0 interface to the LAN it works.

But we need the 3g uplink for the remote working...

 

Must I configure something?

modeswitch?

tty?

 

 

Thanks

Regular Contributor I

Re: HUAWEI E353 don´t work with RAP 3wn

This is what the ap-driver log says:

 


2.4.2
drivers/usb/serial/usb-serial.c: USB Serial support registered for generic
drivers/usb/serial/usb-serial.c: USB Serial Driver core
SCSI subsystem initialized
usb_storage: Ignoring new-style parameters in presence of obsolete ones
Initializing USB Mass Storage driver...
USB Mass Storage support registered.
Port Status 1c000004
ath-ehci ath-ehci.0: ATH EHCI
ehci_reset Intialize USB CONTROLLER in host mode: 13
ehci_reset Port Status 1c000000
ath-ehci ath-ehci.0: new USB bus registered, assigned bus number 1
ath-ehci ath-ehci.0: irq 3, io mem 0x1b000000
ehci_reset Intialize USB CONTROLLER in host mode: 13
ehci_reset Port Status 1c000000
ath-ehci ath-ehci.0: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
USB Device: 0x00000000
USB Product: ATH EHCI
USB Manufacturer: Linux 2.6.16 ehci_hcd
USB SerialNumber: ath-ehci.0
usb usb1: c->desc.bMaxPower 0, udev->busmA 0
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
usb 1-1: new high speed USB device using ath-ehci and address 2
USB Device: 0x12d11446
USB Product: HUAWEI Mobile
USB Manufacturer: Huawei Technologies
USB SerialNumber: <NULL>
usb 1-1: c->desc.bMaxPower 250, udev->busmA 500
usb 1-1: configuration #1 chosen from 1 choice
scsi0 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
scsi1 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
ip_time_handler: Got ip and packets on bond0 Started master election 4-0
Kernel watchdog refresh ended.
  Vendor: HUAWEI    Model: Mass Storage      Rev: 2.31
  Type:   CD-ROM                             ANSI SCSI revision: 02
  Vendor: HUAWEI    Model: TF CARD Storage   Rev:     
  Type:   Direct-Access                      ANSI SCSI revision: 02
 1:0:0:0: Attached scsi generic sg0 type 0
usb-storage: device scan complete
sr0: scsi-1 drive
Uniform CD-ROM driver Revision: 3.20
sr 0:0:0:0: Attached scsi CD-ROM sr0
sr 0:0:0:0: Attached scsi generic sg1 type 5
usb-storage: device scan complete
wlan: 0.8.4.2 (Atheros/multi-bss)
ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 0.9.17.1 (AR5416, AR9380, REGOPS_FUNC, PRIVATE_DIAG, WRITE_EEPROM, 11D)
ath_rate_atheros: Copyright (c) 2001-2005 Atheros Communications, Inc, All Rights Reserved
ath_rate_atheros: Aruba Networks Rate Control Algorithm
ath_dfs: Version 2.0.0
Copyright (c) 2005-2006 Atheros Communications, Inc. All Rights Reserved
ath_spectrum: Version 2.0.0
Copyright (c) 2005-2006 Atheros Communications, Inc. All Rights Reserved
ath_dev: Copyright (c) 2001-2007 Atheros Communications, Inc, All Rights Reserved
ath_ahb: 0.9.4.5 (Atheros/multi-bss)
ath_ahb: init_ath_wmac
Restoring Cal data from Flash
Reading from Addr: 0xbffe100

 


Anybody an idea?

New Contributor

Re: HUAWEI E353 don´t work with RAP 3wn

I'm having a similar problem with a Pantech UML290 and RAP 109.    The following section from the log repeats with the "address" number counting up from 2 to as high as 12.

 

usb 1-1: USB disconnect, address 6
usb 1-1: new high speed USB device using ath-ehci and address 7
USB Device: 0x106c3718
USB Product: PANTECH UML290
USB Manufacturer: Pantech, Incorporated
USB SerialNumber: <NULL>
usb 1-1: c->desc.bMaxPower 250, udev->busmA 500
usb 1-1: configuration #1 chosen from 1 choice
cdc_acm 1-1:1.0: ttyACM0: USB ACM device
usb 1-1: USB disconnect, address 7
usb 1-1: new high speed USB device using ath-ehci and address 8
USB Device: 0x106c3718
USB Product: PANTECH UML290
USB Manufacturer: Pantech, Incorporated
USB SerialNumber: <NULL>
usb 1-1: c->desc.bMaxPower 250, udev->busmA 500
usb 1-1: configuration #1 chosen from 1 choice
cdc_acm 1-1:1.0: ttyACM0: USB ACM device
usb 1-1: USB disconnect, address 8

 

Was there a solution to this post?

Regular Contributor I

Re: HUAWEI E353 don´t work with RAP 3wn

No, my huawei usb modem don´t work yet.

 

But I found something for you sharrison72.

Maybe it helps you:

 

Capture.JPG

 

Verizon Pantech UM150
config t
provision-ap
read-bootinfo ap-name <ap name>
usb-type acm
usb-dev 0x106c3711
link-priority-cellular 110
link-priority-ethernet 100
reprovision ap-name <ap name>
end

 


Verizon Pantech UM175
config t
provision-ap
read-bootinfo ap-name <ap name>
usb-type acm
usb-dev 0x106c3714
link-priority-cellular 110
link-priority-ethernet 100
reprovision ap-name <ap name>
end

 

Verizon Pantech UML290
config t
provision-ap
read-bootinfo ap-name <ap name>
usb-type pantech-3g
4g-usb-type pantech-lte
link-priority-cellular 110
link-priority-ethernet 100
reprovision ap-name <ap name>

end

 

 

 

 

Give Kodus if it helps ...

New Contributor

Re: HUAWEI E353 don´t work with RAP 3wn

Thanks!  Will test this afternoon.

New Contributor

Re: HUAWEI E353 don´t work with RAP 3wn

Thanks for the lead, but that didn't work -- it appears the command "4g-usb-type pantech-lte" is no longer supported.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: