Wireless Access

Reply
Occasional Contributor I
Posts: 5
Registered: ‎12-06-2011

Help with DHCP and VLANs

[ Edited ]

I've searched this forum and others for some advice, but haven't found any applicable tips yet for my situation. (I very likely overlooked relevant posts, so feel free to point me in the right direction. This is my first Aruba setup, so bear with me.)

 

I've run into DHCP and VLAN issues. I can see my SSID, but when I connect I get an automatic private address in the 169.x.x.x range. Basically, I want my campus Windows 2008 DHCP server to pass DHCP to my wireless clients instead of using the built-in DHCP server on the Aruba controller. My controller IP address is on VLAN 4, which is the same VLAN as my DHCP server. I want my wireless clients to be on VLAN 38.

 

On the Configuration tab, under Network>IP>IP Interface do I select "Use the following IP address" and enter the router IP address for the wireless VLAN? My wireless VLAN ID is 38 and the interface on my core router is 172.18.38.1. I entered this address and subnet, along with the DHCP Helper Address for my DHCP server, but my APs continuously rebooted, and I could not connect to the SSID. So I changed to "Obtain an IP address from DHCP". The APs stopped rebooting and let me connect to the SSID, but now I get the 169.x.x.x address.

Aruba Employee
Posts: 117
Registered: ‎09-21-2010

Re: Help with DHCP and VLANs

[ Edited ]

It depends on how your network setup is. If your controller is trunked to the router then the router should take care of the DHCP services, you just need to create a L2 VLAN on the controller for users, in your case just define VLAN 38 in the VLAN section on configuration and specify  VLAN 38 in the Virtual AP profile.

 If you want the controller to act as DHCP relay agent for VLAN 38, then cerate VLAN 38, define an IP for this VLAN and then add the DHCP helper info. Make sure you  add VLAN 38 to the Virtual AP profile. 

 

The users getting 169.x.x.x address means they are not being assigned an IP by the DHCP server, the client is assigning itself an IP address in  this range since it doesn't get any reply for its DHCP discover process.

 

I highly recommended that you go through the campus VRD available at http://www.arubanetworks.com/pdf/technology/VRD_Campus_Networks.pdf . This will explain all the profile and VLAN configurations, redundancy setup, mobility setup and the various other best practices. All other aruba validated reference design docs are available at http://www.arubanetworks.com/vrd

 

Occasional Contributor I
Posts: 5
Registered: ‎12-06-2011

Re: Help with DHCP and VLANs

Thank you for the links, I'll read them!

Aruba Employee
Posts: 117
Registered: ‎09-21-2010

Re: Help with DHCP and VLANs

To answer your question,  First create a VLAN 38 under the VLAN tab. Then on the Configuration tab, under Network>IP>IP Interface (select VLAN 38) you should select  "Use the following IP address" and add an IP for this VLAN from the same subnet (172.18.38.x). Don't add the VLAN 38 IP of the router (172.18.38.1) here . Now your DHCP helper address will be the IP address of the DHCP server.  


Aruba Employee
Posts: 27
Registered: ‎04-02-2007

Re: Help with DHCP and VLANs

Just to add some debug assistance that others may also find useful.  You can enable debugging for the DHCP process and see the steps that are successful.

 

First enable logging for the DHCP process.  On the command line it is this command.  You need to be in configuration mode.

"logging level debugging network subcat dhcp"

Then simply examine the network log using "show log network <number>" where number is the last number of entries to display.

 

You can filter on a specific MAC address if you wish by adding "| include <mac>" to the command string.

 

What you should be able to see is the Discover, the Offer, the Request, and finally the ACK.  One thing to observe is in the VLAN ID.  Make sure it matches what you believe is the correct VLAN.

 

Occasional Contributor I
Posts: 5
Registered: ‎12-06-2011

Re: Help with DHCP and VLANs

Awesome, thanks. I'm finding the command line more and more useful versus the GUI.

Search Airheads
Showing results for 
Search instead for 
Did you mean: