Wireless Access

Reply
Occasional Contributor II

IAP-105 Limited connected when using static vlan

Hi,

 

I am trying to setup an IAP-105 with static vlan assignment but encountered an issue. When I connect to the SSID, it gives me limited or no connectivity. When I change it to Default or use virtual controller, I can connect fine. Is there some settings that I miss? Any help is appreciated.

 

Thanks

 

Oliver

Aruba

Re: IAP-105 Limited connected when using static vlan

How have you setup your provisioned VLANS to be assigned? In current IAP code its perhaps slightly deceiving that if you want the IAP to assign a VLAN or DHCP scope - you actually need to set this as "NETWORK" assigned in the GUI and then of course have your corresponding VLAN's configured.

 

Put up a sample SSID to denote this:

 

wlan ssid-profile IAP-Guest

enable

index 0

type guest

essid IAP-Guest

opmode opensystem

max-authentication-failures 0

vlan 15,16

auth-server InternalServer

rf-band all

captive-portal internal

dtim-period 1

inactivity-timeout 1000

broadcast-filter none

dmo-channel-utilization-threshold 90

local-probe-req-thresh 0

max-clients-threshold 64

 

 

ip dhcp IAP-Pool

server-type Local

server-vlan 15

subnet 192.168.15.0

subnet-mask 255.255.255.0

 

ip dhcp IAP-Pool2

server-type Local

server-vlan 16

subnet 192.168.16.0

subnet-mask 255.255.255.0

 

dhcp.png

 

 

Cheers, Adam



| Adam Kennedy, Systems Engineer - adamk@hpe.com

| Service Providers – Aruba, an HPE Company

| Twitter: @adam8021x | Airheads: akennedy
Occasional Contributor II

Re: IAP-105 Limited connected when using static vlan

Thanks for the information. I'll play around with it.

Occasional Contributor II

Re: IAP-105 Limited connected when using static vlan

Hi, 

 

I am getting parse error when I tried to enter the code below.

ip dhcp IAP-Pool

server-type Local

server-vlan 10

subnet 192.168.10.0

subnet-mask 255.255.255.0

 

Is there any other way I can create ip dhcp pool? What I have observed when I setup the the SSID using Network Assigned and Default is it gets automatically ip address from the DHCP that I setup. Below is the config for the SSID with static VLAN.

 

 

wlan ssid-profile Instant_Test_Static
index 2
type employee
essid Instant_Test_Static
opmode opensystem
max-authentication-failures 0
vlan 10
rf-band all
captive-portal disable
dtim-period 1
inactivity-timeout 1000
broadcast-filter none
blacklist

 

Name:
Aruba Operating System Software
Type:
105
Build Time:
2012-04-26 06:05:05 PDT
Version:
6.1.3.1-3.0.0.0_33460

 

Thanks

 

Oliver

Aruba

Re: IAP-105 Limited connected when using static vlan

Oliver, first I'd suggest you upgrade your code stream to something a little more current. There have been numerous enhancements since the 3.0 IAP code base not to mention bug fixes.

 

In the 3.4 code stream:

 

To configure Local, Local,L3, and Centralized,L2 DHCP scopes:
1. Click More>DHCP Server at the top right corner of the Instant Main window. The DHCP Server window is displayed.
2. To configure a Local, Local,L3, or Centralized,L2 DHCP scopes, click New under Other DHCP Scopes. The New DHCP Scope window is displayed. The following figure shows the contents of the New DHCP Scope window.

 

Untitled.png

 

If you want to do this in the newly supported CLI in the IAP (3.4):

 

To configure Local DHCP scope:
(Instant Access Point)(config)# ip dhcp <profile-name>
(Instant Access Point)(DHCP Profile<profile-name>)# server-type <Local>
(Instant Access Point)(DHCP Profile<profile-name>)# server-vlan <vlan-ID>
(Instant Access Point)(DHCP Profile<profile-name>)# subnet <IP-address>
(Instant Access Point)(DHCP Profile<profile-name>)# subnet-mask <subnet-mask>
(Instant Access Point)(DHCP Profile<profile-name>)# dns-server <name>
(Instant Access Point)(DHCP Profile<profile-name>)# domain-name <domain-name>
(Instant Access Point)(DHCP Profile<profile-name>)# lease-time <minutes>
(Instant Access Point)(DHCP Profile<profile-name>)# option <type> <value>
(Instant Access Point)(DHCP Profile<profile-name>)# end
(Instant Access Point))# commit apply

 

When you then define your SSID paramentres, set the mode to NETWORK and select your prevsioulsy defined VLAN/DHCP scopes and you should be good to go.

 

Cheers, Adam



| Adam Kennedy, Systems Engineer - adamk@hpe.com

| Service Providers – Aruba, an HPE Company

| Twitter: @adam8021x | Airheads: akennedy
Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: