Wireless Access

Reply
Contributor II
Posts: 48
Registered: ‎12-17-2012

IPv6 DHCP issue

Hello,

 

I have an interesting phenomenon with DHCPv6.

 

My clients - MacBook Pro running El Capitan and Lenovo laptop running Windows 7 - get an IPv6 address from my DHCP server when they are connected with a LAN cable but they cannot get an IPv6 address when they are on WiFi.

 

I have a 7210 controller with ArubaOS 6.4.4.2. I have

  • enabled IPv6 globally
  • assigned a IPv6 address to the VLAN interface
  • clients are in "authenticated" role

The DHCPv6 server is on the same VLAN as the clients, hence there is no routing involved.

 

Is there anything on the controller that could prevent DHCPv6 UDP packets from being forwarded?

 

Thanks so much for your help!

 

cheers,

Harald

Guru Elite
Posts: 8,322
Registered: ‎09-08-2010

Re: IPv6 DHCP issue

What role are the users in?

Tim Cappalli | Aruba Security TME
@timcappalli | timcappalli.me | ACMX #367 / ACCX #480
Contributor II
Posts: 48
Registered: ‎12-17-2012

Re: IPv6 DHCP issue

They are in "authenticated" role.

Guru Elite
Posts: 8,322
Registered: ‎09-08-2010

Re: IPv6 DHCP issue

Please try creating a new role with only allowall and v6-allowall.


Tim Cappalli | Aruba Security TME
@timcappalli | timcappalli.me | ACMX #367 / ACCX #480
Contributor II
Posts: 48
Registered: ‎12-17-2012

Re: IPv6 DHCP issue

I have created a new role as you suggested.

 

When I compare it to the "authenticated" role, the new role is missing the ra-guard firewall policy.

 

However, I still get no DHCPv6 packets on my DHCPv6 server. As soon as I reconnect the laptop on the wired network, the request comes in and is being processed.

Frequent Contributor II
Posts: 109
Registered: ‎11-11-2008

Re: IPv6 DHCP issue

*bump*

 

Did you guys find a solution for this problem.

Facing a similar issue at a customer

 

Roar Fossen

Search Airheads
Showing results for 
Search instead for 
Did you mean: