Wireless Access

Reply
Occasional Contributor I

Issues with LACP and AP 325, speed incompatibility

Hi!

I'm currently trying to configure LACP over the two ethernet ports that the AP325 has. It works for about 5 minutes, then the AP reboots and after that only one ethernet interface is up.

From the command "debug lacp" I get the information that one interface is disabled because of speed incompatibility. The accesspoint is connected to a Cisco switch with gigabit interfaces.

We are running ArubaOS 6.5.3.0.

What could be wrong?

 

 

I have configured the following in the aruba controller:

 

 

AP LACP LMS map information
---------------------------
Parameter Value
--------- -----
AP LACP Striping IP Enabled
GRE Striping IP 172.23.28.12 LMS 192.168.36.12

We are using Cisco 3650 with the following config:

 

 

interface GigabitEthernet1/0/1
 description VPC-1-Aruba
 switchport access vlan 222
 switchport mode access
 channel-group 1 mode active

interface GigabitEthernet1/0/2
 description VPC-1-Aruba
 switchport access vlan 222
 switchport mode access
 channel-group 1 mode active

interface Port-channel1
 description VPC-Aruba1-2
 switchport access vlan 222
 switchport mode access

 

Output from debug lacp:

 

(arubamaster) #show ap debug lacp ap-name Alm-test

AP LACP GRE Striping IP: 172.23.28.12

AP LACP Status
--------------
Link Status  LACP Rate  Num Ports  Actor Key  Partner Key  Partner MAC
-----------  ---------  ---------  ---------  -----------  -----------
Up           slow       1          17         1            a0:23:9f:4c:7e:00

Slave Interface Status
----------------------
Slave I/f Name  Permanent MAC Addr  Link Status  Member of LAG  Link Fail Count
--------------  ------------------  -----------  -------------  ---------------
eth0            44:48:c1:c0:97:ae   Up           Yes            0
eth1            44:48:c1:c0:97:af   Up           No             0

NOTE: LACP is disabled on one of the ports due to link speed incompatibility.

GRE Traffic Received on Enet Ports
----------------------------------
Radio Num  Enet 0 Rx Count  Enet 1 Rx Count
---------  ---------------  ---------------
0          0                0
1          0                0
non-wifi   595              0

Traffic Sent on Enet Ports
--------------------------
Radio Num  Enet 0 Tx Count  Enet 1 Tx Count
---------  ---------------  ---------------
0          0                0
1          0                0
non-wifi   652              381 

 

 

Aruba Employee

Re: Issues with LACP and AP 325, speed incompatibility

Hi Fredrik,

 

Please provide the following information:

 

1. How is the ethernet port profile (Enet 0 & Enet 1) configured on the controller  for the AP that you are trying to use ?

 

2. Please attach output for following as well

 

show ap debug system-status ap-name <name of AP> | include Power

 

3.  The LMS IP configured in AP LACP profile should match the LMS IP configured in the AP system profile.

 

in your case, I am seeing the GRE striping IP to be different subnet than the LMS IP that you have mentioned.

 

GRE striping IP should be in same network as the LMS IP.

 

GRE Striping IP 172.23.28.12 LMS 192.168.36.12

 

Aruba Employee

Re: Issues with LACP and AP 325, speed incompatibility

Please connect a laptop to the switchport where you are trying to connect E1 of the AP.

 

This will tell us about the speed/duplex negotiation seen on that port 

 

Note: Port-channel settings might have to removed during the above test to bring up the port.

Occasional Contributor I

Re: Issues with LACP and AP 325, speed incompatibility

1. 

(arubamaster) # show ap wired-ap-profile default

Wired AP profile "default"
--------------------------
Parameter                 Value
---------                 -----
Wired AP enable           Disabled
Trusted                   Not Trusted
Forward mode              tunnel
Switchport mode           access
Access mode VLAN          1
Trunk mode native VLAN    1
Trunk mode allowed VLANs  1-4094
Broadcast                 Broadcast



(arubamaster) # show ap wired-port-profile default

AP wired port profile "default"
-------------------------------
Parameter                                   Value
---------                                   -----
Wired AP profile                            default
Ethernet interface link profile             default
AP LLDP profile                             default
Shut down                                   No
Remote-AP Backup                            Enabled
AAA Profile                                 N/A
Bridge Role                                 N/A
Time to wait for authentication to succeed  20 sec
Spanning Tree                               Disabled
Portfast                                    Disabled
Portfast on trunk                           Disabled

 

2. 

(arubamaster) # show ap debug system-status ap-name Alm-test | include Power
Channel Power Request Information
Channel Power Request Response  Counters
Power Status
Power Supply                : POE-AF
LLDP Power                  : 0.0W

3. I thought that the GRE Striping IP was routable but after som searching it seems that some have had issues with this and recommend to use same subnet.

My setup is configured with two controllers, one master and one standby. They have redundancy with VRRP so they have one IP each and one in common, the LMS IP.

After I enabled GRE Striping IP we got some issues on all our existing 325 APs and users was not able to use our wifi. This setting affects all AP that has the same LMS IP you configure with the LACP LMS. 

In order to test this I would like to create a new LMS IP for my testing 325 APs. Is it possible to use multiple LMS IP adresses on one controller? Seems that this is not possible and when I try the APs gets connected but with the invalid and dirty flag, 2ID.

 

If it is not possible to have multiple LMS IP, could I use for example my master IP in the VRRP configuration for the GRE Striping IP since it has to be in the same subnet?

 

Aruba Employee

Re: Issues with LACP and AP 325, speed incompatibility

Occasional Contributor I

Re: Issues with LACP and AP 325, speed incompatibility

Hi Nitesh,

 

Thanks for the link! Now I understand how to configure it.

 

Another side effect about this, all APs that is able to use LACP and is connected to the LMS IP will get the s-flag.

Do you know if it is possible to use multiple LMS ip on a controller? I would like to split our existing APs that is connected to 192.168.36.12 and use another LMS IP for the new 325 APs. I have created with VRRP 172.23.28.12 and configured an AP system to use this IP. But the APs comes up with the invalid and dirty flag. Is it only possible to have one switch IP?

 

Master controller:

IP: 192.168.36.10

LMS IP: 192.168.36.12 VRRP

GRE IP: 192.168.36.13

IP: 172.23.28.10

LMS IP: 172.23.28.12 VRRP ???????????

 

Standby controller:

IP: 192.168.36.11

LMS IP: 192.168.36.12 VRRP

GRE IP: 192.168.36.14

IP: 172.23.28.11

LMS IP: 172.23.28.12 VRRP??????

Aruba Employee

Re: Issues with LACP and AP 325, speed incompatibility

Hi Fredrik,

 

Is there a specific need/reason for using different LMS for AP-325?

 

Is the existing LMS unreachable for the 325's ?

Occasional Contributor I

Re: Issues with LACP and AP 325, speed incompatibility

Hi Nitesh,

The reason is that I want to seperate the existing 325 APs that is only connected with one interface and the new 325 APs that will be connected with two interfaces.

In order to not affect the existing live environment.

Aruba Employee

Re: Issues with LACP and AP 325, speed incompatibility

Hi Fredrik,

 

I am assuming you are not planning to use AP LACP for the existing AP's which are connected using single interface.

 

Please try the following to see if it helps:

 

1. Create a VRRP instance on the new interface as well

 

172.23.28.x

 

You can make use of this VRRP IP

 

2. Make sure the new AP's have reachability to this interface.

 

3. Create a new AP-group &  a new AP system profile.

 

LMS IP in the new AP system profile will be VRRP IP on 172.23.28.x.

 

4. Provision the AP on this new group & see if it works fine.

 

In case the issues are still there, you can open a TAC case.

 

 

Occasional Contributor I

Re: Issues with LACP and AP 325, speed incompatibility

Hi Nitesh,


Thanks for your help. I have configured as you specify but I still have problem with invalid and dirty flag when using a new LMS IP for the new AP-group. Will contact Aruba TAC and see what could be wrong.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: