Wireless Access

Reply
Contributor I
Posts: 29
Registered: ‎02-09-2012

PXE Boot IBM Server

Hi

 

We are trying to PXE boot a server using an Aruba switch as DHCP server.

Here is my configuration:

ip dhcp pool "Test"
    domain-name "xxxx.net"
    network 192.168.125.0 255.255.255.0
    default-router 192.168.125.1
    dns-server 8.8.8.8
    exclude-address 192.168.125.1 192.168.125.10
    no vendor-class-identifier
    option 67 text SMSboot\x64\wdsnbp.com
    option 66 ip 172.16.1.23

The server seems to ignore option 66, and tries to load from the switch IP.

I have tried with several vendor-class-identifiers ArtubaAP TestVendot PXEclient and more.

 

Do any of you have any idea what the next step in this could be.

 

Best Regards Jens Willadsen

Regards Jens W
Aruba
Posts: 1,368
Registered: ‎12-12-2011

Re: PXE Boot IBM Server

Do you have this working with another DHCP server?

Seth R. Fiermonti
Consulting Systems Engineer - ACCX, ACDX, ACMX
Email: seth@hpe.com
-----
If you found my post helpful, please give kudos
Contributor I
Posts: 29
Registered: ‎02-09-2012

Re: PXE Boot IBM Server

No this is the first DHCP we have tested it with.

The inviroment where the server should be shipped to has only an Aruba switch as possible DHCP server 

Regards Jens W
MVP
Posts: 1,412
Registered: ‎11-30-2011

Re: PXE Boot IBM Server

i would compare with a sniffer the packets send when it works (with another DHCP server) and when it doesnt to see if something stands out.

Contributor I
Posts: 29
Registered: ‎02-09-2012

Re: PXE Boot IBM Server

Hi

I have just today made a capture of the DHCP trafic i se when my PC is getting a DHCP address.

My pool is set up like this:

ip dhcp pool "Test"
   domain-name "xxxxxxxx.net"
   network 172.16.xxx.0 255.255.255.0
   default-router 172.16.xxx.1
   dns-server 8.8.8.8
   exclude-address 172.16.xxx.1 172.16.xxx.50
   vendor-class-identifier ArubaAP
   option 67 text SMSboot\x64\wdsnbp.com
   option 66 ip 172.16.1.23

 

I have attached a screen shot of the DHCP ACK packet i wireshark

 

Regards Jens

Regards Jens W
MVP
Posts: 1,412
Registered: ‎11-30-2011

Re: PXE Boot IBM Server

the ACK isnt that interesting, i would look at the OFFER and see if the info is there.

 

looking you are using symbols like / that might cause issues.

New Contributor
Posts: 1
Registered: ‎10-05-2016

Re: PXE Boot IBM Server

Hello, 

having similar issue,

did you find any solution on this???

 

I am hip dhcp pool "test"
domain-name "xyz.com"
network 192.168.XX.0 255.255.255.128
default-router 192.168.XX.1
dns-server xx.xx.xx.xx

dns-server xx.xx.xx.xx
exclude-address 192.168.xx.1 192.168.xx.30
vendor-class-identifier ArubaAP
option 66 ip 10.xx.xx.xx
option 67 text boot\x64\wdsnbp.com

 

please let me know if anything you may find in this, which I require to add

 

MVP
Posts: 1,412
Registered: ‎11-30-2011

Re: PXE Boot IBM Server

kinda repeating myself but: i would compare with a sniffer the packets send when it works (with another DHCP server) and when it doesnt to see if something stands out.

 

i see \  in that one section, might be an issue, but impossible to say without the packet details.

Search Airheads
Showing results for 
Search instead for 
Did you mean: