Wireless Access

Reply
Occasional Contributor I
Posts: 8
Registered: ‎05-28-2009

Problem with IPhones connecting to Guest network with Captive Portal

Wondering if anyone has seen similar issues. 

 

We are experiencing an issue with Iphones connecting to a guest SSID with "guest" Captive Portal authentication. The platform is two 6000 based controllers running AruabOS 6.1.3.4 in an VRRP configuration. 

 

When an iphone device connects to the guest network some are experiencing intermittent issues where they will associate to the ssid successfully, however from there users can't get a captive portal login.  Upon further investigation it appears that when this occurs, the devices are not recieving a DHCP address (which is assigned from the controller).  During testing, other devices (standard pc's, macbooks, etc.) all connect fine.  Resolution is to either "Forget this Network" and reconnect the device or reboot the device, which so far in all cases solves the problem temporarily.

 

 

Guru Elite
Posts: 21,280
Registered: ‎03-29-2007

Re: Problem with IPhones connecting to Guest network with Captive Portal

Please consult the page here:  http://community.arubanetworks.com/t5/ArubaOS-and-Mobility-Controllers/Captive-Portal-Welcome-Page/m-p/31554/highlight/true#M2788 for a possible workaround.

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Search Airheads
Showing results for 
Search instead for 
Did you mean: