Wireless Access

Reply
Occasional Contributor II
Posts: 57
Registered: ‎04-01-2010

RAP not getting IP from RAP pool

All,

 

I am trying to migrate some RAPs over from M3 controllers to some newer 7220 controllers.  The RAPs work fine on the M3, but I canot get an IP address from the RAP pool when I connected it up to the 7220.  I think I am missing something small.

 

Dec 31 00:22:06 :103063: <DBUG> |ike| get_ikev2_internal_ip pool Rap_pool
Dec 31 00:22:06 :103061: <ERRS> |ike| Unable to get get IP Address from pool

 

Thanks,

 

Bill

Guru Elite
Posts: 8,456
Registered: ‎09-08-2010

Re: RAP not getting IP from RAP pool

Does each 7200 controller have a VPN address pool defined? 


Thanks, 
Tim

Tim Cappalli | Aruba Security TME
@timcappalli | timcappalli.me | ACMX #367 / ACCX #480
Aruba
Posts: 1,644
Registered: ‎04-13-2009

Re: RAP not getting IP from RAP pool

Do you have a pool named Rap_pool on the 7220?

 

What is the output of:

 

show vpdn l2tp local pool

------------------------------------------------
Systems Engineer, Northeast USA
ACCX | ACDX | ACMX

Occasional Contributor II
Posts: 57
Registered: ‎04-01-2010

Re: RAP not getting IP from RAP pool

Yes it does.  I have it defined as the same pool as the one on the M3.  I am using 172.16.10.11 - 172.16.10.20.

Aruba
Posts: 1,644
Registered: ‎04-13-2009

Re: RAP not getting IP from RAP pool

Please share the output of the following from the 7220.

 

show vpdn l2tp local pool

 

 

------------------------------------------------
Systems Engineer, Northeast USA
ACCX | ACDX | ACMX

Occasional Contributor II
Posts: 57
Registered: ‎04-01-2010

Re: RAP not getting IP from RAP pool

Here's the output.

 

#show vpdn l2tp local pool

IP addresses used in pool Rap_Pool
none

Total:-
0 IPs used - 10 IPs free - 10 IPs configured
IP pool allocations / de-allocations - L2TP: 0/0 IKE: 583/0

 

 

Aruba
Posts: 1,644
Registered: ‎04-13-2009

Re: RAP not getting IP from RAP pool

Are you assigning the L2TP pool name from the default RAP role?   It looks like from your log that it is looking for the pool named Rap_pool; but on your 7220 it is Rap_Pool.  Please delete the Rap_Pool on the 7220 and recreate as Rap_pool (case sensitive).

------------------------------------------------
Systems Engineer, Northeast USA
ACCX | ACDX | ACMX

Occasional Contributor II
Posts: 57
Registered: ‎04-01-2010

Re: RAP not getting IP from RAP pool

That did the trick.  It was using the default RAP role.  l didn't realize the RAP pool definition was case sensitive.  All is connecting up fine.

 

Thanks for the help.

Occasional Contributor II
Posts: 57
Registered: ‎04-01-2010

Re: RAP not getting IP from RAP pool

quick question clembo.  Where do you find where the default profile that uses the IPSec address pool?

Aruba
Posts: 1,644
Registered: ‎04-13-2009

Re: RAP not getting IP from RAP pool

[ Edited ]

The RAPs are assigned a role by the controller.  For classic RAPs, it will use the system role ap-role.  If you specify an L2TP pool in that role, the RAPs will request an IP from that pool.   For RAP-NG, the default-vpn-role is used.

 

 

 aos-rap-l2tp.png

 

------------------------------------------------
Systems Engineer, Northeast USA
ACCX | ACDX | ACMX

Search Airheads
Showing results for 
Search instead for 
Did you mean: