Wireless Access

Reply
Occasional Contributor II

Sticky clients after controller upgrade

It feels like sticky clients is an issue that never goes away. We are almost complete with a controller upgrade to 7210’s from 3600’s. We also replaced all of the AP-65’s with 205’s and left the 105. The 3600’s are running 6.2.1.8 (we still have one site that needs the 65’s replaced so it is still on the old controllers), the 7210’s 6.4.3.7.

 

We are not only seeing this issue at the locations that we replaced the AP’s at but also at the locations that had ap-105’s and still do, they have only been moved to the new controllers. Here is an example that I was able to fix. New Dell laptops when roaming would show the connection icon with the “limited connection” icon. It would still be connected to the SSID but it could not even ping it’s gateway and required a disconnect/reconnect. Updating the drivers fixed this. I now also have Microsoft Surface users, of different model types, that are doing the same thing. This one is harder to reproduce, but the drivers are on the newest that MS has released, and they do not allow for any roaming aggressiveness options in the drivers, very frustrating. And I was just told of a Fujitsu laptop model that is having the same issues, though mine does not. On the old controllers/older AOS/ same AP model we had no issues and now we do. We currently have HT and VHT disabled. I disabled HT and that seemed to help, but I don’t want to leave it that way. I am beginning to think that I need to move to a different AOS version. I see that 6.4.3.9 is out, but perhaps there is a more proven stable, trouble free code version? 

Guru Elite

Re: Sticky clients after controller upgrade

- Yes, upgrade drivers

- No, do not adjust roaming settings for clients, because that will not scale

- Enable HT and VHT...otherwise you are just throwing away money.

- The best way to start dealing with sticky clients is to lower the max-tx-power in the ARM profile by 3dbm, to start.

- AP205s are much more sensitive and transmit much better than AP105s, so clients will more easily be attracted to them.

 

If those things do not work, let us know and we can try something else.

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Occasional Contributor II

Re: Sticky clients after controller upgrade

Thank you Colin.

I did read the sticky about HT and VHT, I'll look into that. I know that enabling and disabling HT does not disrupt the network. Can I assume the same for VHT?

 

max-tx-power, is that 'max tx EIRP'? That is set to 127 (default), the next level down is 33 which seems like a large jump. All of the other options under 33 are by 3.

I noticed that we have 'min tx EIRP' set to 18 but the default is 9. Should that change?

 

Levin

MVP

Re: Sticky clients after controller upgrade

You are basically letting your AP's blow at near max power.

Setting either 127 or 33 won't make one bit of difference as both will most likely be over the limit your regulatory domain allows.

 

How much the min and max should be depends on your deployment and is hard to tell for us.

But start with a 'show ap active' to see what the APs are currently using.. are most at 18? if so, lower both min and tx, keep them seperated by 2 levels  (eg. max 21, min 15).

 

 

Koen (ACMX #351 | ACDX #547 | ACCP)

-- Found something helpful, important, or cool? Click the Kudos Star in a post.
-- Problem Solved? Click "Accept as Solution" in a post.
Guru Elite

Re: Sticky clients after controller upgrade


ldavie wrote:

Thank you Colin.

I did read the sticky about HT and VHT, I'll look into that. I know that enabling and disabling HT does not disrupt the network. Can I assume the same for VHT?

 

max-tx-power, is that 'max tx EIRP'? That is set to 127 (default), the next level down is 33 which seems like a large jump. All of the other options under 33 are by 3.

I noticed that we have 'min tx EIRP' set to 18 but the default is 9. Should that change?

 

Levin


Start with the min TX power at 12 and the max at 18.  That basically makes the AP power match the range of the clients you will be deploying.  Asymetric power causes issues like sticky clients.  Test after you make those changes.

 

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Occasional Contributor II

Re: Sticky clients after controller upgrade

Thanks to you both. I’ve changed the min/max to 12/18. I also found something else that I am sure was causing problems: “Local Probe Request Threshold” had been set to 35 on the older code, as this is what we found worked best on that code (6.2) to help sticky clients to roam, but is way too high on the 6.4 code we are now on (something I found in the forum here). I changed this to 10 since Client Match is enabled. Colin, you mentioned that we should enable HT and VHT, and I also read your sticky on the subject. I have a question about that. There are two places that this can be set, in the 802.11a radio profile as shown in your post, and also in the SSID profile. Without it being set in both places the LED’s on the AP will not go green. If I just make the change on the radio profile, is that done to improve connection quality, and the SSID profile change will increase connection speeds?
Guru Elite

Re: Sticky clients after controller upgrade

Please set it in both...

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Occasional Contributor II

Re: Sticky clients after controller upgrade

After changing the min tx to 12 and max to 18 we have had a few devices that are a ways away from an AP have some disconnect issues, we have a sparse AP deployment. Other than installing a closer AP, I would like to increase power. If I increase the TX to 21, is it important to raise the min to 15 to keep a 2 step separation, or is that a minimum rule, not an always rule?

Guru Elite

Re: Sticky clients after controller upgrade

Did you set the local probe request threshold to 0 first?  That should be your first step.



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Occasional Contributor II

Re: Sticky clients after controller upgrade

I did not, I set it to 10 as per this post http://community.arubanetworks.com/t5/Wireless-Access/Client-Match-and-Local-Probe-Request-Threshold/td-p/249785 and that made a huge difference and improved things imediately. I will make it 0 if you think that is better then increasing TX level.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: