Wireless Access

Reply
Contributor I
Posts: 21
Registered: ‎06-11-2013

Unable to access the controller from the browser

Anyone have any ideas on how to fix this error would be greatly appreciated?

 

/etc/init.d/rcS: 298: cannot create /flash/webcert/cnname: Directory nonexistent

 

I have even tried to downgrade the version and then upgrade again to 6.2

 

I am unable to access the controller (651 controller) from the browser. I was upgrading partition 0 and when the controller rebooted i started receiving the error. I also receive the error even when i boot to partition 1 now

 

I was upgrading from 6.1 to 6.2

 

I am also unable to restore flash from my backup as it states "Error untar'ing file.". I have tried copying it back to flash via scp/tftp

 

Thanks in advance

Aruba Employee
Posts: 39
Registered: ‎04-11-2007

Re: Unable to access the controller from the browser

Are you able to access the controller via the console port?

 

I would suggest that you contact Aruba support to help you get this issue resolved. Send an email to support@arubanetworks.com or refer to this page for global phone numbers :

 

http://www.arubanetworks.com/support-services/aruba-support-program/contact-support/

 

Regards,

Mark

Contributor I
Posts: 21
Registered: ‎06-11-2013

Re: Unable to access the controller from the browser

mverbloot,

 

thanks for your reply..

 

Yes, i am able to access the controller via the console..

 

I was hoping this would be an easy fix like just run his command  8)

 

I purchased this controller/RAP5's and AP125 off of eBay since my school district would not purchase me an extra equipment for learning purposes since they spent $3 mil on the system. They advised me to wait until after the system is in place and they would see about extra equipment.

 

I do not have a warranty or a support contract for the controller.. 

Aruba Employee
Posts: 39
Registered: ‎04-11-2007

Re: Unable to access the controller from the browser

OK then.

 

Please send the output from the console port when the controller is booting up so we can see what is happening.

 

Regards,

Mark

MVP
Posts: 4,271
Registered: ‎07-20-2011

Re: Unable to access the controller from the browser

 

Is this controller in a live environment  ?

 

See if you can do the following :

 

https://arubanetworkskb.secure.force.com/pkb/articles/HowTo/R-1000

Thank you

Victor Fabian
Lead Mobility Engineer @ Integration Partners
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
Contributor I
Posts: 21
Registered: ‎06-11-2013

Re: Unable to access the controller from the browser

Thank you both for the replies...

 

I will try the recommended fix by VFabian later this evening as i am in wireless meetings all day.

 

VFabian do you think there may be any issues since i am unable to restore the last flash backup now or do you believe it should work once the partition is formated? FYI - i know the backup is good as i have restored flash with it before..

 

Thanks again mverbloot & vfabian

 

I'll post the outcome tonight..

 

 

MVP
Posts: 4,271
Registered: ‎07-20-2011

Re: Unable to access the controller from the browser

 

 

It is possible that when you did the restore there wasn't enough space.

 

 

Thank you

Victor Fabian
Lead Mobility Engineer @ Integration Partners
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
Contributor I
Posts: 21
Registered: ‎06-11-2013

Re: Unable to access the controller from the browser

Not sure if i am not doing something correctly but when i type in the following i get:

 

cpboot> format 0:2
Unknown command 'format' - try 'help'

 

any suggestions?

 

Thanks

Contributor I
Posts: 21
Registered: ‎06-11-2013

Re: Unable to access the controller from the browser

[ Edited ]

mverbloot,

 

here is a screenshot of the boot process. I am looking up the proper way to capture the logs so i can send them

 

Thanks for the help

 

Update here is info from the messages log (not sure if it helps):

      <CRIT> |authmgr|  Loading Certificate from /flash/webcert/cert.pem failed Jun 20 08:50:07

         authmgr[2272]: <132144> <CRIT> |authmgr| Failed to download the cert for dot1x-termination
Jun 20 08:50:08

 

 

Contributor I
Posts: 21
Registered: ‎06-11-2013

Re: Unable to access the controller from the browser

[ Edited ]

UPDATE: i did a backup flash and then compared it to a known good backup and it does not contain the folder "webcert" and inside this folder are 3 files named cnname, cert.pem and ca.cert.bundle.pem

 

the error state "cannot create /flash/webcert/cnname: Directory nonexistent" this makes sense as the directory "webcert" is not there

 

so is there a way to create the folder manually as i am still unable to do a restore flash?

 

UPDATE #2: I have tried to take the "webcert" folder from the known good backup and then place it in the backup that was missing it and then tar.gz'd it but i am still unable to restore the file. Not sre if there is a check sum that may be causing the error or if it is something else. The size of the new flashbackup.tar.gz ir 28 KB, even with the "webcert" folder added. So i don't think it is an out of space issue...

 

Thanks in advance

Search Airheads
Showing results for 
Search instead for 
Did you mean: