Wireless Access

Reply
Occasional Contributor I
Posts: 7
Registered: ‎04-30-2015

Users constantly have to sign in to captive portal

Hello Airheads Community,

 

We have an ongoing problem with users having to constantly sign on to captive portal. What happens is as follows.

 

User connects to wifi, signs in, goes to web page, has to sign in again, surfs the web maybe 10 seconds, maybe 2 hours, has to sign in again. Sometimes the user has to sign in 5 or 6 times before they will stay connected. This happens on all typs of devices, Mac, Windows, Phones etc, and regarless of how close they are to an access point. It will even happen while sitting directly under one. There seems to be no set time when this happens to, sometimes a month or more will go by with out an issue, then it starts again. We have checked everything that we can think of an nothing has worked. Everything as far as we can tell is set to stay authenticated for 12 hours.

 

APs are a mix of 105s and 125s connected to 2 Aruba 7210 controllers running Aruba OS 6.4.4.5 but this issue has been on going for several OS versions.

MVP
Posts: 4,225
Registered: ‎07-20-2011

Re: Users constantly have to sign in to captive portal

Do you have ClearPass ? or Planning to ?
Thank you

Victor Fabian
Lead Mobility Engineer @ Integration Partners
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
Guru Elite
Posts: 20,761
Registered: ‎03-29-2007

Re: Users constantly have to sign in to captive portal


JesseLamb-WACOIT wrote:

Hello Airheads Community,

 

We have an ongoing problem with users having to constantly sign on to captive portal. What happens is as follows.

 

User connects to wifi, signs in, goes to web page, has to sign in again, surfs the web maybe 10 seconds, maybe 2 hours, has to sign in again. Sometimes the user has to sign in 5 or 6 times before they will stay connected. This happens on all typs of devices, Mac, Windows, Phones etc, and regarless of how close they are to an access point. It will even happen while sitting directly under one. There seems to be no set time when this happens to, sometimes a month or more will go by with out an issue, then it starts again. We have checked everything that we can think of an nothing has worked. Everything as far as we can tell is set to stay authenticated for 12 hours.

 

APs are a mix of 105s and 125s connected to 2 Aruba 7210 controllers running Aruba OS 6.4.4.5 but this issue has been on going for several OS versions.


- Where do you have it set for 12 hours?

- What is your DHCP scope lease time?

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Occasional Contributor I
Posts: 7
Registered: ‎04-30-2015

Re: Users constantly have to sign in to captive portal

We currently have Clearpass but it is only being utilized for the guest network and that actually goes live this week. 

MVP
Posts: 4,225
Registered: ‎07-20-2011

Re: Users constantly have to sign in to captive portal

What are using that other captive portal for ?
Thank you

Victor Fabian
Lead Mobility Engineer @ Integration Partners
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
Occasional Contributor I
Posts: 7
Registered: ‎04-30-2015

Re: Users constantly have to sign in to captive portal

Under Security- User Roles- Edit Roles (Student) the Re-authentication Interval is set for 720 min.

 

DHCP Lease time is: 15 hours and is controlled by our DHCP server and not the controller.

 

Under the user rolls all other uset types are also set for 720 min, Staff, Faculty, etc.

 


cjoseph wrote:

JesseLamb-WACOIT wrote:

Hello Airheads Community,

 

We have an ongoing problem with users having to constantly sign on to captive portal. What happens is as follows.

 

User connects to wifi, signs in, goes to web page, has to sign in again, surfs the web maybe 10 seconds, maybe 2 hours, has to sign in again. Sometimes the user has to sign in 5 or 6 times before they will stay connected. This happens on all typs of devices, Mac, Windows, Phones etc, and regarless of how close they are to an access point. It will even happen while sitting directly under one. There seems to be no set time when this happens to, sometimes a month or more will go by with out an issue, then it starts again. We have checked everything that we can think of an nothing has worked. Everything as far as we can tell is set to stay authenticated for 12 hours.

 

APs are a mix of 105s and 125s connected to 2 Aruba 7210 controllers running Aruba OS 6.4.4.5 but this issue has been on going for several OS versions.


- Where do you have it set for 12 hours?

- What is your DHCP scope lease time?

 


 

Occasional Contributor I
Posts: 7
Registered: ‎04-30-2015

Re: Users constantly have to sign in to captive portal


Victor Fabian wrote:
What are using that other captive portal for ?

Captive Portal is used for Student, Faculty, Staff logins on our Academic wireless.

Guru Elite
Posts: 20,761
Registered: ‎03-29-2007

Re: Users constantly have to sign in to captive portal


JesseLamb-WACOIT wrote:

Under Security- User Roles- Edit Roles (Student) the Re-authentication Interval is set for 720 min.

 

DHCP Lease time is: 15 hours and is controlled by our DHCP server and not the controller.

 

Under the user rolls all other uset types are also set for 720 min, Staff, Faculty, etc.

 


cjoseph wrote:

JesseLamb-WACOIT wrote:

Hello Airheads Community,

 

We have an ongoing problem with users having to constantly sign on to captive portal. What happens is as follows.

 

User connects to wifi, signs in, goes to web page, has to sign in again, surfs the web maybe 10 seconds, maybe 2 hours, has to sign in again. Sometimes the user has to sign in 5 or 6 times before they will stay connected. This happens on all typs of devices, Mac, Windows, Phones etc, and regarless of how close they are to an access point. It will even happen while sitting directly under one. There seems to be no set time when this happens to, sometimes a month or more will go by with out an issue, then it starts again. We have checked everything that we can think of an nothing has worked. Everything as far as we can tell is set to stay authenticated for 12 hours.

 

APs are a mix of 105s and 125s connected to 2 Aruba 7210 controllers running Aruba OS 6.4.4.5 but this issue has been on going for several OS versions.


- Where do you have it set for 12 hours?

- What is your DHCP scope lease time?

 


 


That parameter is used for FORCED reauthentication.  You should set that parameter back to zero...

 

In the Captive Portal authentication profile, there is a user idle timeout parameter.  That is what you edit to allow users to not have to logon after "x" seconds of inactivity.  The maximum will get you 4.5 hours of inactivity before users are forced to re-logon.  There is a catch, though; the DHCP lease time for those users needs to be 2x the user-idle timeout so that old users with old leases do not end up in the user table.  The second catch is that those users, while not idle will still appear in the user table for 4.5 hours, giving you an artificially inflated view of the user table.  Long story short: use ClearPass Guest with mac caching to allow Captive Portal users to get on without having to logon so often..



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Occasional Contributor I
Posts: 7
Registered: ‎04-30-2015

Re: Users constantly have to sign in to captive portal

In the last 24 hours this issue has gotted substantially worse. Users myself included have to repeatedly sign on sometimes within seconds. This is not normal and I have no idea what to check. For example today I had to sign in not an exaggeration 8 times in an hour, 4 times in 15min and once was sign on, navagate to a webpage immediately have to sign on again. When looking at my account on the controller it did show that I was connected for 1min after signing back in. Up until today on my personal device (iPhone 6plus running iOS 9.3.1)

 

This is what should happen and did happen with Aruba 5.0 on our old controllers.

Users signs in after 2 hours of no activity they are logged off.

If user is active then they stay logged in for 12 hours

They should be able to wander around campus and buildings with out being disconnected as long as the idle and max continuous useage timers have not been met.

If once user has been on for 12 hours they have to log back in.

 

Ever since the upgrade to 7210 controllers and Aruba OS 6.3.x we have been having users complain about this disconnect issue and it seems to come and go. There will be months where everything is working then daily this issue. I do not know much about Aruba and came on board after this implementation was completed and need some direction.

 

Clearpass has been a recent purchase (a month or two ago) and was only planned for our guest network not our enduser (student, faculty, staff) network so for the time being we need to get this issue resolved on the controller side.

I appologize for being short on information but I don't have much to give, this happens on all devices, windows, mac, ios, android, so there isn't any specific OS version or device type that I can narrow it down. This also happens regardless of how close the AP is located. A use could be sitting directly under an AP and get booted.

Guru Elite
Posts: 20,761
Registered: ‎03-29-2007

Re: Users constantly have to sign in to captive portal

[ Edited ]

Sound like an RF issue.  Did you open a TAC case?

 

PM me your email address and I will send you a link to send me your logs.tar

 

 

 



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Search Airheads
Showing results for 
Search instead for 
Did you mean: