Wireless Access

Reply
Aruba Employee

VIA Client autostart

Hi all

 

I installed 64-bit VIA Client 3.2.1.0.101689 a few days ago on a Win 10 Pro. It keeps on autostarting.

 

I've been searching for a way to disable the autostart. From Airheads forums I found suggestion to just delete it from the Win Start folder. Done that, but every time I start it, it will reinsert itself.

 

In another thread someone said this can be disabled from the client settings. There's no option for that at all.

 

Arubavnic.inf -file contains this part:

 

[Strings]
   DeviceDescription = "Aruba Virtual Adapter"
   Provider = "Aruba Networks"
   MTU      = "MTU"
   MediaStatus = "Media Status"
   ApplicationControl = "Application Controlled"
   Always             = "Always Connected"

 

Is this "Always Connected" the culprit? If yes, what should be the value to make it manually startable?

 

If this isn't it, how the devil do I stop it?

 

 

For developers:

 

While autostart can be convenient, it's not always so. It's not something I need first thing when I login. Not every VPN:d network is reachable with VIA client - I need currently three others.

 

So please consider making autostart a user-configurable option. I see no technical reason why it has to start with Windows. Seems to work just fine when you start it manually when Windows is already running.

Frequent Contributor II

Re: VIA Client autostart

I had this issue too for a while but here is what I ended up doing. 

On windows 7 boxes, I pulled up MSCONFIG, went to the STARTUP tab and then removed/disabled VIA from there. In Windows 8/10 boxes, same principle, but done from the START tab in Task Manager. As far as Macs go, well, you are on your own there ;-)

 

 

Scott McNeil - Sr. Network & Security Engineer, Global Process Automation
Network+ | CWNA | CWTS | ACSP | ACMP | ACMA | BREC
Guru Elite

Re: VIA Client autostart


@ wrote:

Hi all

 

I installed 64-bit VIA Client 3.2.1.0.101689 a few days ago on a Win 10 Pro. It keeps on autostarting.

 

I've been searching for a way to disable the autostart. From Airheads forums I found suggestion to just delete it from the Win Start folder. Done that, but every time I start it, it will reinsert itself.

 

In another thread someone said this can be disabled from the client settings. There's no option for that at all.

 

Arubavnic.inf -file contains this part:

 

[Strings]
   DeviceDescription = "Aruba Virtual Adapter"
   Provider = "Aruba Networks"
   MTU      = "MTU"
   MediaStatus = "Media Status"
   ApplicationControl = "Application Controlled"
   Always             = "Always Connected"

 

Is this "Always Connected" the culprit? If yes, what should be the value to make it manually startable?

 

If this isn't it, how the devil do I stop it?

 

 

For developers:

 

While autostart can be convenient, it's not always so. It's not something I need first thing when I login. Not every VPN:d network is reachable with VIA client - I need currently three others.

 

So please consider making autostart a user-configurable option. I see no technical reason why it has to start with Windows. Seems to work just fine when you start it manually when Windows is already running.


Do you mean startup automatically or make the connection automatically?  The option to make the connection automatically is dictated by the controller configuration auto-login:  http://www.arubanetworks.com/techdocs/ArubaOS_6_5_4_X_Web_Help/Web_Help_Index.htm#ArubaFrameStyles/1CommandList/aaa_authentication_via_c.htm?Highlight=auto-login



Colin Joseph
Aruba Customer Engineering

Looking for an Answer? Search the Community Knowledge Base Here: Community Knowledge Base

Aruba Employee

Re: VIA Client autostart

Thank you Scott! That did the trick.

 

This really should be a client configuration item, not hidden in Windows settings.

 

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: