Wireless Access

Reply
Contributor II

VMC 8.1 DHCP relay issue.

Hi guy,

 

I have the scenario below that client cannot obtian IP from router (act as DHCP server). If PC is in same network of VLAN2, it can access to internet. 

I also make the controller act as DHCP server and gatway point to Router. This also did not work for wireless client;.

VLAN 1 Managaemnt

VLAN 2 Guest (Role Logon)

What should I do?Secario ED.png

 

 

 

Thank you,
Ratchapas S.

Re: VMC 8.1 DHCP relay issue.

Hello, 

 

  • Are the routing ok between your vlans ?
  • Does the clients be able to reach the router ?
  • Why you are not using the Aruba as DHCP server ?

 

Thanks in advance for your feedback.

 

+

Contributor II

Re: VMC 8.1 DHCP relay issue.

Hi,

 

- Yes, routing is running on router. I tested on only one vlan and the result is the same.

- Yes, clients reached the router and it shown log from correctly source.

- I tested with DHCP server enable on the controller but client will not reach to the router.

I think the root cause is at the controller because wired network can access to the internet as well.

Thank you,
Ratchapas S.
New Contributor

Re: VMC 8.1 DHCP relay issue.

Hi, here nearly the same problem.

New Controller installed with 8.1, now on 8.2 on VMware.

All VLANs are tagged forwarded to VMC and APs.

Firewall or Windows Server is DHCP depending on Network.

 

First step only WPA2 personal.

 

No problems with default vlan untagged.

 

I added a IPv4 address to the VLAN and set DHCP to none.

When I connect to WiFi I can see in firewall log the DHCP Offer and discover (incoming from correct VLAN 90) But Smartphone get no IP.

When I change to DHCP Helper Address I can see in firewall request and ack with information tht it comes from configured helper address.

Again no IP at the client.

Windows Client get ip addresses with cable connections in untagged vlans.

 

interface gigabitethernet 0/0/0
    description "GE0/0/0"
    trusted
    trusted vlan 1-4094
    no poe
    switchport mode trunk
    switchport access vlan 90
    no spanning-tree
!


wlan virtual-ap "company-VW"
    aaa-profile "company-VW"
    vlan OfficeLAN
    ssid-profile "company-VW"
!

aaa profile "company-VW"
    authentication-dot1x "company-VW"
    enforce-dhcp
!
wlan ssid-profile "company-VW"
    essid "company-VW"
    opmode wpa2-psk-aes
    wpa-passphrase ...
!

 

Any idea?

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: