Wireless Access

Reply
Occasional Contributor I

iOS devices

I'm a newbie to Aruba, just had a new Aruba system installed Monday. 

My Android connects to the captive portal and keeps it's connect until I leave at the end of the day or out of range.  My users running iPhones and iPads are dropping their connection and have to reauthenticate once the device locks.  I know this is not an Aruba problem but more of the iOS devices shutting down the radio when it locks.

 

I'm wondering what a workaround might be?

 

TIA

Aruba

Re: iOS devices

like you said, the issue is not Aruba specific, but there are a couple of things you can look at.

 

The first is the default user idle timeout setting (on the advanced tab of the Authentication section on the controller).   This setting is used by the controller to clear idle sessions.    When it determines a client is idlel (by the timer) it will send a probe to the client to see if it is online and sitting idle; or truly offline (this includes when an iOS device sleeps).    if the client responds, the timer is reset.   if the client does not respond, it's session is cleared.   In this case, the client would need to reauthenticate the next time they connect (the symptom you are seeing).  You can try increasing this timeout; but beware, this is a global setting for all user sessions.

 

The second relies on ClearPass Guest.....you can get around this by tying MAC-Auth to the captive portal logons.   The user may be asked to logon the first time each day; but subsequent attempts can be handled by MAC-Auth of the device.

------------------------------------------------
Systems Engineer, Northeast USA
ACCX | ACDX | ACMX

Occasional Contributor I

Re: iOS devices

Exactly the information I was looking for.  Thank you very much!!!!!

 

Talked to apple support and I guess this is a known issue.  Their workaround is as follows just in cse others need it.

 

Don't select your network from the list of available networks select "Other..." and manually enter your network config and join.  I've tried it on a few iOS devices and it works.

 

 

Regular Contributor II

Re: iOS devices

Thanks I was having the same issue.

Search Airheads
cancel
Showing results for 
Search instead for 
Did you mean: