Wireless Access

Reply
Occasional Contributor II
Posts: 16
Registered: ‎11-12-2014

iOS showing "Success" after connecting in stead of going to redirect URL

[ Edited ]

Hi all,

 

We are having an issue with our guest network. We have a controller setup and Clearpass (using the Web Logins option to setup a captive portal, controller initiated)    

 

The following occurs:

 

  • User connect to the guest ssid
  • On iPhone 7 (latest update) a pop-up occurs (which is a good thing!) This is the Apple Captive Network Assistant
  • User sees a page where he/she needs to confirm the Terms and Conditions and click “Connect”
  • After this the iPhone user sees "Success" --> see attached file
  • It seems this is http://captive.apple.com/
  • I read some documentation and as far as I understand this URL is used to verify network connectivity. It should not be displayed.
  • We have set a redirect URL (where the host should go to after successfully establishing a connection), however, in this case that doesn’t work. We just get “Success” and nothing more.

 

Ideally the user should be redirected after successfully connecting. What could be wrong?

 

We tried experimenting with “Force default destination for all clients” and “Enable bypassing the Apple Captive Network Assistant” but this doesn’t help.

 

Any suggestions on how to solve this?

MVP
Posts: 514
Registered: ‎11-04-2011

Re: iOS showing "Success" after connecting in stead of going to redirect URL

It looks like you almost solved the issue. This indeed looks like the client is redirected in the end to Apple's connectivity testing page.

How it should work, is that iOS tests if that page is reachable after the user connected to the network, as soon as you device detects a redirect it will pop-up the screen (what works...).

In the end, the user should be redirected to your corporate homepage (or some other page), and the popup screen should disappear on the phone. That is not happening.

What might help is to go with another device through the whole process and see what is happening. It looks to me that the final redirect is not happening, and that should be the same for other clients. Check this video on how captive portal should work and some troubleshooting tips, specifically check the attributes in the URLs and forms.

 

If that does not allow you to find and solve the issue, please ask your partner or Aruba TAC for assistance to do some more in-depth troubleshooting.

--
If you have urgent issues, please contact your Aruba partner or Aruba TAC (click for contact details).
Occasional Contributor II
Posts: 16
Registered: ‎11-12-2014

Re: iOS showing "Success" after connecting in stead of going to redirect URL

Hi Herman, thanks for your reply!

 

Yesterday we tested this on an iPhone 6 plus and iPhone 5s and iPhone 7. All 3 devices are on the latest iOS. They all have this behaviour, so they all show the white "Success" page.

 

I would expect that, if the Apple Captive Assistant is used, that nothing is diplayed: no "Success" and no redirect to our homepage after setting up a successfull connection. If a normal browser is used I would expect a redirect to our homepage.

 

Is this an iOS issue or a Aruba Clearpass issue?

Occasional Contributor II
Posts: 16
Registered: ‎11-12-2014

Re: iOS showing "Success" after connecting in stead of going to redirect URL

Just did a test to compare:

 

Our "old" SMS login, using "Guest Self-Registrations" works fine, after connecting, even with the Apple Captive Assist browser, our homepage is shown, and no "Success" page is displayed.

 

WIth our new, simpeler setup, using "Web Logins", the "Success" page is displayed.

MVP
Posts: 514
Registered: ‎11-04-2011

Re: iOS showing "Success" after connecting in stead of going to redirect URL

I tend to follow you on that the captive network assistant should not show the Success page, but based on that page should close itself as there is open connectivity.

 

If you search Google for 'Apple IOS page shows Success', it looks like you are not alone, it is not just Aruba, and it seems something of all times (not just recently).

 

My personal feeling is that you will need to follow all the steps that are happening, and see what is different. What also may help is to test if older iOS versions do or don't experience the issue, and if the issue is existing on both controller and Instant (I believe you have both flavors in your network).

 

What also may give additional information is to capture traffic and see what is the difference between your old workflow and the new one on client behavior. And could the timing be part of it? What if you wait for 20 seconds before you 'Accept and continue'?

 

Please work with your partner and/or Aruba TAC if you get stuck during troubleshooting. And if you find the answer, I'm pretty sure other Airheads will appreciate hearing what you found and what is the solution.

--
If you have urgent issues, please contact your Aruba partner or Aruba TAC (click for contact details).
Occasional Contributor II
Posts: 16
Registered: ‎11-12-2014

Re: iOS showing "Success" after connecting in stead of going to redirect URL

After some more testing... the problem is solved, by activating "Force default destination for all clients".

This is a bit odd since we experimented with this yesterday. But anyways, now, with "Force default destination for all clients" set enabled, it works as expected, and the "Success" page is not shown.

 

Thanks for the help!

Search Airheads
Showing results for 
Search instead for 
Did you mean: