Wireless Access

Reply
Regular Contributor II
Posts: 219
Registered: ‎10-09-2009

iPhone 5s connecting to wrong network

A few users that have iPhone 5s have experineced that when they come in the phone connects directly to the guest network instead of the network that we setup for phones. I can go in and switch it on the phone to the correct network and it is fine until they go home and then come back in the morning. All the other iPhone versions and Androids. I have told the iPhone to forget the guest network and it is fine for the day. This only started yesterday nothing has been changed on the wireless side for over a month.

We are running ArubaOS version 5.1.3.5.

Guru Elite
Posts: 8,628
Registered: ‎09-08-2010

Re: iPhone 5s connecting to wrong network

[ Edited ]

I believe there is a new setting on iOS 7 that will auto connect to open networks without the user ever manually connecting.

 

Android seems to have taken the right road in 4.3 and will not connect to (and even block if you want) open networks when there is a saved secure network in range.


Tim Cappalli | Aruba Security TME
@timcappalli | timcappalli.me | ACMX #367 / ACCX #480
Regular Contributor II
Posts: 219
Registered: ‎10-09-2009

Re: iPhone 5s connecting to wrong network

[ Edited ]

Thanks for the quick reply. I have a 4s and my boss has a 5 both running the latest version of the IOS (7.0.4) same as the 5s. Our phones connect just fine. Which is confusing all are running the same version of IOS but the newest hardware has the issue. The issue only started yesterday late morning.

MVP
Posts: 1,409
Registered: ‎05-28-2008

Re: iPhone 5s connecting to wrong network

Apple...and iphones...really sucks in Wi-Fi... I like you prefer Android.

But...

 

Just delete the uneeded Wi-Fi profile that the user itself (by purpose or by mistake) add to his iPhone5s.

iPhone5s , even with 7.0 will not connect to an OPEN Wi-Fi network of no previos profile already done by the user itself.

 

 

 

*****************2Plus Wireless Solutions****************************
Aruba Airheads - Powered By community for empower the community
************ Don't Forget to Kudos + me,If i helped you******************
Regular Contributor II
Posts: 219
Registered: ‎10-09-2009

Re: iPhone 5s connecting to wrong network

The network they want to connect to is open. The one the should is secured. Which makes it more confusing.

MVP
Posts: 4,301
Registered: ‎07-20-2011

Re: iPhone 5s connecting to wrong network

I seen this issue before and in order to fix I usually reset the network settings and then connect to the SSID that you want the phone to connect to.

 

If you just forget the network it will reconnect again if the device connected at one point.

 

Not sure if you have tried that ?

Thank you

Victor Fabian
Lead Mobility Engineer @ Integration Partners
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
Regular Contributor II
Posts: 219
Registered: ‎10-09-2009

Re: iPhone 5s connecting to wrong network

Vic, yes i have reset the network settings.
MVP
Posts: 4,301
Registered: ‎07-20-2011

Re: iPhone 5s connecting to wrong network

Interesting

Thank you

Victor Fabian
Lead Mobility Engineer @ Integration Partners
AMFX | ACMX | ACDX | ACCX | CWAP | CWDP | CWNA
Aruba
Posts: 1,377
Registered: ‎12-12-2011

Re: iPhone 5s connecting to wrong network

Do these users have a MAC/iPad or other apple device?  If so, do they have keychain access in the cloud?  I have seen this recently where I am on my Macbook and connect to an SSID...a minute or so later, the iOS device is also connected to the same SSID but I NEVER TOLD IT TO CONNECT!!!

 

This is true for both open and PSK SSIDs out there FYI...

Seth R. Fiermonti
Consulting Systems Engineer - ACCX, ACDX, ACMX
Email: seth@hpe.com
-----
If you found my post helpful, please give kudos
Regular Contributor II
Posts: 219
Registered: ‎10-09-2009

Re: iPhone 5s connecting to wrong network

It's just IPhones. The users only have the phone. The users use Windows based computer at their homes and here at the office.

Search Airheads
Showing results for 
Search instead for 
Did you mean: